p PatchFirst

PatchFirst · Latest vulnerabilities

poppler vulnerabilities

Vulnerabilities published for poppler in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 50

  1. CVE-2019-9959

    Medium · CVSS 6.5EPSS 1.91%Fix available

    CVE-2019-9959

    The JPXStream::init function in Poppler 0.78.0 and earlier doesn't check for negative values of stream length, leading to an Integer Overflow, thereby making it possible to allocate a large memory chunk on the heap, with a size controlled by an attacker, as demonstrated by pdftocairo.

    • Update to 0.41.0-0ubuntu1.15
    Published Updated
  2. CVE-2019-13283

    High · CVSS 7.8EPSS 1.13%Fix available

    CVE-2019-13283

    In Xpdf 4.01.01, a heap-based buffer over-read could be triggered in strncpy from FoFiType1::parse in fofi/FoFiType1.cc because it does not ensure the source string has a valid length before making a fixed-length copy. It can, for example, be triggered by sending a crafted PDF document to the pdftotext tool. It allows an attacker to use a crafted pdf file to cause Denial of Service or an information leak, or possibly have unspecified other impact.

    • Update to 0.41.0-0ubuntu1.15
    Published Updated
  3. CVE-2019-9200

    High · CVSS 8.8EPSS 3.47%Fix available

    CVE-2019-9200

    A heap-based buffer underwrite exists in ImageStream::getLine() located at Stream.cc in Poppler 0.74.0 that can (for example) be triggered by sending a crafted PDF file to the pdfimages binary. It allows an attacker to cause Denial of Service (Segmentation fault) or possibly have unspecified other impact.

    • Update to 0.41.0-0ubuntu1.13
    Published Updated
  4. CVE-2019-7310

    High · CVSS 8.8EPSS 2.07%Fix available

    CVE-2019-7310

    In Poppler 0.73.0, a heap-based buffer over-read (due to an integer signedness error in the XRef::getEntry function in XRef.cc) allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted PDF document, as demonstrated by pdftocairo.

    • Update to 0.41.0-0ubuntu1.12
    Published Updated
  5. CVE-2018-20662

    Medium · CVSS 6.5EPSS 2.26%Fix available

    CVE-2018-20662

    In Poppler 0.72.0, PDFDoc::setup in PDFDoc.cc allows attackers to cause a denial-of-service (application crash caused by Object.h SIGABRT, because of a wrong return value from PDFDoc::setup) by crafting a PDF file in which an xref data structure is mishandled during extractPDFSubtype processing.

    • Update to 0.41.0-0ubuntu1.14
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →