p PatchFirst

CVE-2019-12468

CVE-2019-12468

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.27.0 through 1.32.1. Directly POSTing to Special:ChangeEmail would allow for bypassing re-authentication, allowing for potential account takeover.

CVSS 9.8 · Critical · EPSS 3.3% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • mediawiki Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:1.31.2-1

    Update to 1:1.31.2-1

  • mediawiki Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:1.31.2-1

    Update to 1:1.31.2-1

  • mediawiki Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:1.31.2-1

    Update to 1:1.31.2-1

  • mediawiki/core Packagist

    Versions
    • 1.27.0
    • 1.27.1
    • 1.27.2
    • 1.27.3
    • 1.27.4
    • 1.27.5
    Affected ranges
    • ECOSYSTEM: ≥ 1.27.0, < 1.27.6

    Update to 1.27.6

  • mediawiki/core Packagist

    Versions
    • 1.30.0
    • 1.30.1
    Affected ranges
    • ECOSYSTEM: ≥ 1.30.0, < 1.30.2

    Update to 1.30.2

  • mediawiki/core Packagist

    Versions
    • 1.31.0
    • 1.31.1
    Affected ranges
    • ECOSYSTEM: ≥ 1.31.0, < 1.31.2

    Update to 1.31.2

  • mediawiki/core Packagist

    Versions
    • 1.32.0
    • 1.32.1
    Affected ranges
    • ECOSYSTEM: ≥ 1.32.0, < 1.32.2

    Update to 1.32.2

  • mediawiki Ubuntu:18.04:LTS

    Versions
    • 1:1.27.3-1
    • 1:1.27.4-1
    • 1:1.27.4-2
    • 1:1.27.4-3
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →