CVE-2019-12749
CVE-2019-12749
This page contains facts from public vulnerability sources. Check the original advisory before updating.
dbus before 1.10.28, 1.12.x before 1.12.16, and 1.13.x before 1.13.12, as used in DBusServer in Canonical Upstart in Ubuntu 14.04 (and in some, less common, uses of dbus-daemon), allows cookie spoofing because of symlink mishandling in the reference implementation of DBUS_COOKIE_SHA1 in the libdbus library. (This only affects the DBUS_COOKIE_SHA1 authentication mechanism.) A malicious client with write access to its own home directory could manipulate a ~/.dbus-keyrings symlink to cause a DBusServer with a different uid to read and write in unintended locations. In the worst case, this could result in the DBusServer reusing a cookie that is known to the malicious client, and treating that cookie as evidence that a subsequent client connection came from an attacker-chosen uid, allowing authentication bypass.
CVSS 7.1 · High · EPSS 0.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
dbus Debian:12
- Affected ranges
- ECOSYSTEM: < 1.12.16-1
Update to 1.12.16-1
dbus Debian:13
- Affected ranges
- ECOSYSTEM: < 1.12.16-1
Update to 1.12.16-1
dbus Debian:14
- Affected ranges
- ECOSYSTEM: < 1.12.16-1
Update to 1.12.16-1
dbus Ubuntu:Pro:14.04:LTS
- Versions
- 1.6.12-0ubuntu10
- 1.6.18-0ubuntu1
- 1.6.18-0ubuntu2
- 1.6.18-0ubuntu3
- 1.6.18-0ubuntu4
- 1.6.18-0ubuntu4.1
- 1.6.18-0ubuntu4.2
- 1.6.18-0ubuntu4.3
- 1.6.18-0ubuntu4.4
- 1.6.18-0ubuntu4.5
- Affected ranges
- ECOSYSTEM: < 1.6.18-0ubuntu4.5+esm1
Update to 1.6.18-0ubuntu4.5+esm1
dbus Ubuntu:16.04:LTS
- Versions
- 1.10.0-1ubuntu1
- 1.10.4-1ubuntu2
- 1.10.6-1ubuntu1
- 1.10.6-1ubuntu2
- 1.10.6-1ubuntu3
- 1.10.6-1ubuntu3.1
- 1.10.6-1ubuntu3.3
- Affected ranges
- ECOSYSTEM: < 1.10.6-1ubuntu3.4
Update to 1.10.6-1ubuntu3.4
dbus Ubuntu:18.04:LTS
- Versions
- 1.10.22-1ubuntu1
- 1.12.0-1ubuntu1
- 1.12.2-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 1.12.2-1ubuntu1.1
Update to 1.12.2-1ubuntu1.1
Original sources
- https://www.openwall.com/lists/oss-security/2019/06/11/2
- http://www.openwall.com/lists/oss-security/2019/06/11/2
- https://usn.ubuntu.com/4015-1/
- https://usn.ubuntu.com/4015-2/
- https://www.debian.org/security/2019/dsa-4462
- https://seclists.org/bugtraq/2019/Jun/16
- http://www.securityfocus.com/bid/108751
- https://lists.debian.org/debian-lts-announce/2019/06/msg00005.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/V2CQF37O73VH2JDVX2ILX2KD2KLXLQOU/
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00059.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00092.html
- https://access.redhat.com/errata/RHSA-2019:1726
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00026.html
- https://security.gentoo.org/glsa/201909-08
- https://access.redhat.com/errata/RHSA-2019:2868
- https://access.redhat.com/errata/RHSA-2019:2870
- https://access.redhat.com/errata/RHSA-2019:3707
- https://security.netapp.com/advisory/ntap-20241206-0010/
- https://nvd.nist.gov/vuln/detail/CVE-2019-12749