p PatchFirst

PatchFirst · Latest vulnerabilities

dbus vulnerabilities

Vulnerabilities published for dbus in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 28

  1. CVE-2023-34969

    Medium · CVSS 6.5EPSS 1.51%Fix available

    CVE-2023-34969

    D-Bus before 1.15.6 sometimes allows unprivileged users to crash dbus-daemon. If a privileged user with control over the dbus-daemon is using the org.freedesktop.DBus.Monitoring interface to monitor message bus traffic, then an unprivileged user with the ability to connect to the same dbus-daemon can cause a dbus-daemon crash under some circumstances via an unreplyable message. When done on the well-known system bus, this is a denial-of-service vulnerability. The fixed versions are 1.12.28, 1.14.8, and 1.15.6.

    • Update to 1.14.8-1
    Published Updated
  2. CVE-2022-42012

    Medium · CVSS 6.5EPSS 1.77%Fix available

    CVE-2022-42012

    An issue was discovered in D-Bus before 1.12.24, 1.13.x and 1.14.x before 1.14.4, and 1.15.x before 1.15.2. An authenticated attacker can cause dbus-daemon and other programs that use libdbus to crash by sending a message with attached file descriptors in an unexpected format.

    • Update to 1.14.4-1
    Published Updated
  3. CVE-2022-42011

    Medium · CVSS 6.5EPSS 1.77%Fix available

    CVE-2022-42011

    An issue was discovered in D-Bus before 1.12.24, 1.13.x and 1.14.x before 1.14.4, and 1.15.x before 1.15.2. An authenticated attacker can cause dbus-daemon and other programs that use libdbus to crash when receiving a message where an array length is inconsistent with the size of the element type.

    • Update to 1.14.4-1
    Published Updated
  4. CVE-2020-35512

    High · CVSS 7.8EPSS 0.33%Fix available

    CVE-2020-35512

    A use-after-free flaw was found in D-Bus Development branch <= 1.13.16, dbus-1.12.x stable branch <= 1.12.18, and dbus-1.10.x and older branches <= 1.10.30 when a system has multiple usernames sharing the same UID. When a set of policy rules references these usernames, D-Bus may free some memory in the heap, which is still used by data structures necessary for the other usernames sharing the UID, possibly leading to a crash or other undefined behaviors

    • Update to 1.12.20-1
    Published Updated
  5. CVE-2020-12049

    Medium · CVSS 5.5EPSS 0.57%Fix available

    CVE-2020-12049

    An issue was discovered in dbus >= 1.3.0 before 1.12.18. The DBusServer in libdbus, as used in dbus-daemon, leaks file descriptors when a message exceeds the per-message file descriptor limit. A local attacker with access to the D-Bus system bus or another system service's private AF_UNIX socket could use this to make the system service reach its file descriptor limit, denying service to subsequent D-Bus clients.

    • Update to 1.12.18-1
    Published Updated
  6. CVE-2019-12749

    High · CVSS 7.1EPSS 0.55%Fix available

    CVE-2019-12749

    dbus before 1.10.28, 1.12.x before 1.12.16, and 1.13.x before 1.13.12, as used in DBusServer in Canonical Upstart in Ubuntu 14.04 (and in some, less common, uses of dbus-daemon), allows cookie spoofing because of symlink mishandling in the reference implementation of DBUS_COOKIE_SHA1 in the libdbus library. (This only affects the DBUS_COOKIE_SHA1 authentication mechanism.) A malicious client with write access to its own home directory could manipulate a ~/.dbus-keyrings symlink to cause a DBusServer with a different uid to read and write in unintended locations. In the worst case, this could result in the DBusServer reusing a cookie that is k

    • Update to 1.12.16-1
    Published Updated
  7. CVE-2015-0245

    Not ratedEPSS 0.27%Fix available

    CVE-2015-0245

    D-Bus 1.4.x through 1.6.x before 1.6.30, 1.8.x before 1.8.16, and 1.9.x before 1.9.10 does not validate the source of ActivationFailure signals, which allows local users to cause a denial of service (activation failure error returned) by leveraging a race condition involving sending an ActivationFailure signal before systemd responds.

    • Update to 1.8.16-1
    Published Updated
  8. CVE-2014-7824

    Not ratedEPSS 0.59%Fix available

    CVE-2014-7824

    D-Bus 1.3.0 through 1.6.x before 1.6.26, 1.8.x before 1.8.10, and 1.9.x before 1.9.2 allows local users to cause a denial of service (prevention of new connections and connection drop) by queuing the maximum number of file descriptors. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-3636.1.

    • Update to 1.8.10-1
    Published Updated
  9. CVE-2014-3636

    Not ratedEPSS 0.51%Fix available

    CVE-2014-3636

    D-Bus 1.3.0 through 1.6.x before 1.6.24 and 1.8.x before 1.8.8 allows local users to (1) cause a denial of service (prevention of new connections and connection drop) by queuing the maximum number of file descriptors or (2) cause a denial of service (disconnect) via multiple messages that combine to have more than the allowed number of file descriptors for a single sendmsg call.

    • Update to 1.8.8-1
    Published Updated
  10. CVE-2014-3635

    Not ratedEPSS 0.49%Fix available

    CVE-2014-3635

    Off-by-one error in D-Bus 1.3.0 through 1.6.x before 1.6.24 and 1.8.x before 1.8.8, when running on a 64-bit system and the max_message_unix_fds limit is set to an odd number, allows local users to cause a denial of service (dbus-daemon crash) or possibly execute arbitrary code by sending one more file descriptor than the limit, which triggers a heap-based buffer overflow or an assertion failure.

    • Update to 1.8.8-1
    Published Updated
  11. CVE-2014-3532

    Not ratedEPSS 0.45%Fix available

    CVE-2014-3532

    dbus 1.3.0 before 1.6.22 and 1.8.x before 1.8.6, when running on Linux 2.6.37-rc4 or later, allows local users to cause a denial of service (system-bus disconnect of other services or applications) by sending a message containing a file descriptor, then exceeding the maximum recursion depth before the initial message is forwarded.

    • Update to 1.8.6-1
    Published Updated
  12. CVE-2014-3477

    Medium · CVSS 4EPSS 0.44%Fix available

    CVE-2014-3477

    The dbus-daemon in D-Bus 1.2.x through 1.4.x, 1.6.x before 1.6.20, and 1.8.x before 1.8.4, sends an AccessDenied error to the service instead of a client when the client is prohibited from accessing the service, which allows local users to cause a denial of service (initialization failure and exit) or possibly conduct a side-channel attack via a D-Bus message to an inactive service.

    • Update to 1.8.4-1
    Published Updated
  13. CVE-2012-3524

    Not ratedEPSS 4.48%Public exploitFix available

    CVE-2012-3524

    libdbus 1.5.x and earlier, when used in setuid or other privileged programs in X.org and possibly other products, allows local users to gain privileges and execute arbitrary code via the DBUS_SYSTEM_BUS_ADDRESS environment variable. NOTE: libdbus maintainers state that this is a vulnerability in the applications that do not cleanse environment variables, not in libdbus itself: "we do not support use of libdbus in setuid binaries that do not sanitize their environment before their first call into libdbus."

    • Update to 1.6.8-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →