CVE-2019-13283
CVE-2019-13283
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Xpdf 4.01.01, a heap-based buffer over-read could be triggered in strncpy from FoFiType1::parse in fofi/FoFiType1.cc because it does not ensure the source string has a valid length before making a fixed-length copy. It can, for example, be triggered by sending a crafted PDF document to the pdftotext tool. It allows an attacker to use a crafted pdf file to cause Denial of Service or an information leak, or possibly have unspecified other impact.
CVSS 7.8 · High · EPSS 1.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
poppler Ubuntu:16.04:LTS
- Versions
- 0.33.0-0ubuntu3
- 0.37.0-0ubuntu1
- 0.38.0-0ubuntu1
- 0.41.0-0ubuntu1
- 0.41.0-0ubuntu1.1
- 0.41.0-0ubuntu1.2
- 0.41.0-0ubuntu1.3
- 0.41.0-0ubuntu1.4
- 0.41.0-0ubuntu1.5
- 0.41.0-0ubuntu1.6
- 0.41.0-0ubuntu1.7
- 0.41.0-0ubuntu1.8
- 0.41.0-0ubuntu1.9
- 0.41.0-0ubuntu1.10
- 0.41.0-0ubuntu1.11
- 0.41.0-0ubuntu1.12
- 0.41.0-0ubuntu1.13
- 0.41.0-0ubuntu1.14
- Affected ranges
- ECOSYSTEM: < 0.41.0-0ubuntu1.15
Update to 0.41.0-0ubuntu1.15
Original sources
- https://forum.xpdfreader.com/viewtopic.php?f=3&t=41843
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FWEWFUVITPA3Y6F4A5SJSROKYT7PRH7Q/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TNIJWRYTCLGV35WGIHYTMMOPEEOOTIPT/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DJJD7X3ES7ZHJUY2R3DAVCJPV23R64VK/
- https://nvd.nist.gov/vuln/detail/CVE-2019-13283