CVE-2019-14813
CVE-2019-14813
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in ghostscript, versions 9.x before 9.50, in the setsystemparams procedure where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. A specially crafted PostScript file could disable security protection and then have access to the file system, or execute arbitrary commands.
CVSS 7.3 · High · EPSS 11.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
ghostscript
- Versions
- ghostscript versions 9.x before 9.28: Affected
No fix published
ghostscript Debian:12
- Affected ranges
- ECOSYSTEM: < 9.28~~rc2~dfsg-1
Update to 9.28~~rc2~dfsg-1
ghostscript Debian:13
- Affected ranges
- ECOSYSTEM: < 9.28~~rc2~dfsg-1
Update to 9.28~~rc2~dfsg-1
ghostscript Debian:14
- Affected ranges
- ECOSYSTEM: < 9.28~~rc2~dfsg-1
Update to 9.28~~rc2~dfsg-1
ghostscript Ubuntu:16.04:LTS
- Versions
- 9.16~dfsg~0-0ubuntu3
- 9.16~dfsg~0-0ubuntu4
- 9.18~dfsg~0-0ubuntu1
- 9.18~dfsg~0-0ubuntu2
- 9.18~dfsg~0-0ubuntu2.2
- 9.18~dfsg~0-0ubuntu2.3
- 9.18~dfsg~0-0ubuntu2.4
- 9.18~dfsg~0-0ubuntu2.6
- 9.18~dfsg~0-0ubuntu2.7
- 9.18~dfsg~0-0ubuntu2.8
- 9.18~dfsg~0-0ubuntu2.9
- 9.25~dfsg+1-0ubuntu0.16.04.1
- 9.25~dfsg+1-0ubuntu0.16.04.2
- 9.25~dfsg+1-0ubuntu0.16.04.3
- 9.26~dfsg+0-0ubuntu0.16.04.1
- 9.26~dfsg+0-0ubuntu0.16.04.3
- 9.26~dfsg+0-0ubuntu0.16.04.4
- 9.26~dfsg+0-0ubuntu0.16.04.5
- 9.26~dfsg+0-0ubuntu0.16.04.6
- 9.26~dfsg+0-0ubuntu0.16.04.7
- 9.26~dfsg+0-0ubuntu0.16.04.8
- 9.26~dfsg+0-0ubuntu0.16.04.9
- 9.26~dfsg+0-0ubuntu0.16.04.10
- Affected ranges
- ECOSYSTEM: < 9.26~dfsg+0-0ubuntu0.16.04.11
Update to 9.26~dfsg+0-0ubuntu0.16.04.11
ghostscript Ubuntu:18.04:LTS
- Versions
- 9.21~dfsg+1-0ubuntu3
- 9.22~dfsg+1-0ubuntu1
- 9.22~dfsg+1-0ubuntu1.1
- 9.22~dfsg+1-0ubuntu1.2
- 9.25~dfsg+1-0ubuntu0.18.04.1
- 9.25~dfsg+1-0ubuntu0.18.04.2
- 9.26~dfsg+0-0ubuntu0.18.04.1
- 9.26~dfsg+0-0ubuntu0.18.04.3
- 9.26~dfsg+0-0ubuntu0.18.04.4
- 9.26~dfsg+0-0ubuntu0.18.04.5
- 9.26~dfsg+0-0ubuntu0.18.04.6
- 9.26~dfsg+0-0ubuntu0.18.04.7
- 9.26~dfsg+0-0ubuntu0.18.04.8
- 9.26~dfsg+0-0ubuntu0.18.04.9
- 9.26~dfsg+0-0ubuntu0.18.04.10
- Affected ranges
- ECOSYSTEM: < 9.26~dfsg+0-0ubuntu0.18.04.11
Update to 9.26~dfsg+0-0ubuntu0.18.04.11
Original sources
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14813
- http://git.ghostscript.com/?p=ghostpdl.git%3Ba=commitdiff%3Bh=885444fcbe10dc42787ecb76686c8ee4dd33bf33
- https://www.debian.org/security/2019/dsa-4518
- https://lists.debian.org/debian-lts-announce/2019/09/msg00007.html
- https://seclists.org/bugtraq/2019/Sep/15
- https://access.redhat.com/errata/RHSA-2019:2594
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LBUC4DBBJTRFNCR3IODBV4IXB2C2HI3V/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZP34D27RKYV2POJ3NJLSVCHUA5V5C45A/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6AATIHU32MYKUOXQDJQU4X4DDVL7NAY3/
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00090.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00088.html
- https://access.redhat.com/errata/RHBA-2019:2824
- https://security.gentoo.org/glsa/202004-03
- https://nvd.nist.gov/vuln/detail/CVE-2019-14813