CVE-2019-14859
CVE-2019-14859
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in all python-ecdsa versions before 0.13.3, where it did not correctly verify whether signatures used DER encoding. Without this verification, a malformed signature could be accepted, making the signature malleable. Without proper verification, an attacker could use a malleable signature to create false transactions.
CVSS 7.4 · High · EPSS 1.5% · Fix available
- Published
- Updated
Affected products and versions
python-ecdsa
- Versions
- all python-ecdsa versions before 0.13.3: Affected
No fix published
python-ecdsa Debian:12
- Affected ranges
- ECOSYSTEM: < 0.13.3-1
Update to 0.13.3-1
python-ecdsa Debian:13
- Affected ranges
- ECOSYSTEM: < 0.13.3-1
Update to 0.13.3-1
python-ecdsa Debian:14
- Affected ranges
- ECOSYSTEM: < 0.13.3-1
Update to 0.13.3-1
ecdsa PyPI
- Versions
- 0.10
- 0.11
- 0.12
- 0.13
- 0.13.1
- 0.13.2
- 0.6
- 0.7
- 0.8
- 0.9
- Affected ranges
- ECOSYSTEM: < 0.13.3
Update to 0.13.3
ecdsa PyPI
- Versions
- 0.6
- 0.7
- 0.8
- 0.9
- 0.10
- 0.11
- 0.12
- 0.13
- 0.13.1
- 0.13.2
- Affected ranges
- ECOSYSTEM: < 0.13.3
Update to 0.13.3
python-ecdsa Ubuntu:16.04:LTS
- Versions
- 0.13-2
- Affected ranges
- ECOSYSTEM: < 0.13-2ubuntu0.16.04.1
Update to 0.13-2ubuntu0.16.04.1
python-ecdsa Ubuntu:18.04:LTS
- Versions
- 0.13-2
- Affected ranges
- ECOSYSTEM: < 0.13-2ubuntu0.18.04.1
Update to 0.13-2ubuntu0.18.04.1