p PatchFirst

PatchFirst · Latest vulnerabilities

ecdsa vulnerabilities

Vulnerabilities published for ecdsa in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2026-33936

    Medium · CVSS 5.3EPSS 0.48%Fix available

    python-ecdsa: Denial of Service via improper DER length validation in crafted private keys

    The `ecdsa` PyPI package is a pure Python implementation of ECC (Elliptic Curve Cryptography) with support for ECDSA (Elliptic Curve Digital Signature Algorithm), EdDSA (Edwards-curve Digital Signature Algorithm) and ECDH (Elliptic Curve Diffie-Hellman). Prior to version 0.19.2, an issue in the low-level DER parsing functions can cause unexpected exceptions to be raised from the public API functions. `ecdsa.der.remove_octet_string()` accepts truncated DER where the encoded length exceeds the available buffer. For example, an OCTET STRING that declares a length of 4096 bytes but provides only 3 bytes is parsed successfully instead of being rej

    • Update to 0.19.2
    Published Updated
  2. CVE-2024-23342

    High · CVSS 7.4EPSS 0.98%No fix published

    python-ecdsa vulnerable to Minerva attack on P-256

    The `ecdsa` PyPI package is a pure Python implementation of ECC (Elliptic Curve Cryptography) with support for ECDSA (Elliptic Curve Digital Signature Algorithm), EdDSA (Edwards-curve Digital Signature Algorithm) and ECDH (Elliptic Curve Diffie-Hellman). Versions 0.18.0 and prior are vulnerable to the Minerva attack. As of time of publication, no known patched version exists.

    Published Updated
  3. CVE-2019-14859

    High · CVSS 7.4EPSS 1.53%Fix available

    CVE-2019-14859

    A flaw was found in all python-ecdsa versions before 0.13.3, where it did not correctly verify whether signatures used DER encoding. Without this verification, a malformed signature could be accepted, making the signature malleable. Without proper verification, an attacker could use a malleable signature to create false transactions.

    • Update to 0.13.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →