CVE-2019-14869
CVE-2019-14869
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in all versions of ghostscript 9.x before 9.50, where the `.charkeys` procedure, where it did not properly secure its privileged calls, enabling scripts to bypass `-dSAFER` restrictions. An attacker could abuse this flaw by creating a specially crafted PostScript file that could escalate privileges within the Ghostscript and access files outside of restricted areas or execute commands.
CVSS 7.3 · High · EPSS 3.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
ghostscript
- Versions
- all versions of ghostscript 9.x before 9.28: Affected
No fix published
ghostscript Debian:12
- Affected ranges
- ECOSYSTEM: < 9.50~dfsg-3
Update to 9.50~dfsg-3
ghostscript Debian:13
- Affected ranges
- ECOSYSTEM: < 9.50~dfsg-3
Update to 9.50~dfsg-3
ghostscript Debian:14
- Affected ranges
- ECOSYSTEM: < 9.50~dfsg-3
Update to 9.50~dfsg-3
ghostscript Ubuntu:16.04:LTS
- Versions
- 9.16~dfsg~0-0ubuntu3
- 9.16~dfsg~0-0ubuntu4
- 9.18~dfsg~0-0ubuntu1
- 9.18~dfsg~0-0ubuntu2
- 9.18~dfsg~0-0ubuntu2.2
- 9.18~dfsg~0-0ubuntu2.3
- 9.18~dfsg~0-0ubuntu2.4
- 9.18~dfsg~0-0ubuntu2.6
- 9.18~dfsg~0-0ubuntu2.7
- 9.18~dfsg~0-0ubuntu2.8
- 9.18~dfsg~0-0ubuntu2.9
- 9.25~dfsg+1-0ubuntu0.16.04.1
- 9.25~dfsg+1-0ubuntu0.16.04.2
- 9.25~dfsg+1-0ubuntu0.16.04.3
- 9.26~dfsg+0-0ubuntu0.16.04.1
- 9.26~dfsg+0-0ubuntu0.16.04.3
- 9.26~dfsg+0-0ubuntu0.16.04.4
- 9.26~dfsg+0-0ubuntu0.16.04.5
- 9.26~dfsg+0-0ubuntu0.16.04.6
- 9.26~dfsg+0-0ubuntu0.16.04.7
- 9.26~dfsg+0-0ubuntu0.16.04.8
- 9.26~dfsg+0-0ubuntu0.16.04.9
- 9.26~dfsg+0-0ubuntu0.16.04.10
- 9.26~dfsg+0-0ubuntu0.16.04.11
- Affected ranges
- ECOSYSTEM: < 9.26~dfsg+0-0ubuntu0.16.04.12
Update to 9.26~dfsg+0-0ubuntu0.16.04.12
ghostscript Ubuntu:18.04:LTS
- Versions
- 9.21~dfsg+1-0ubuntu3
- 9.22~dfsg+1-0ubuntu1
- 9.22~dfsg+1-0ubuntu1.1
- 9.22~dfsg+1-0ubuntu1.2
- 9.25~dfsg+1-0ubuntu0.18.04.1
- 9.25~dfsg+1-0ubuntu0.18.04.2
- 9.26~dfsg+0-0ubuntu0.18.04.1
- 9.26~dfsg+0-0ubuntu0.18.04.3
- 9.26~dfsg+0-0ubuntu0.18.04.4
- 9.26~dfsg+0-0ubuntu0.18.04.5
- 9.26~dfsg+0-0ubuntu0.18.04.6
- 9.26~dfsg+0-0ubuntu0.18.04.7
- 9.26~dfsg+0-0ubuntu0.18.04.8
- 9.26~dfsg+0-0ubuntu0.18.04.9
- 9.26~dfsg+0-0ubuntu0.18.04.10
- 9.26~dfsg+0-0ubuntu0.18.04.11
- Affected ranges
- ECOSYSTEM: < 9.26~dfsg+0-0ubuntu0.18.04.12
Update to 9.26~dfsg+0-0ubuntu0.18.04.12
Original sources
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14869
- http://www.openwall.com/lists/oss-security/2019/11/15/1
- https://git.ghostscript.com/?p=ghostpdl.git%3Ba=commitdiff%3Bh=485904772c5f
- https://bugs.ghostscript.com/show_bug.cgi?id=701841
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IX55AEDERTDFEZAROKZW64MZRPLINEGI/
- https://seclists.org/bugtraq/2019/Nov/27
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HC4REO73BEJOJAU7NHFHJECAUAYJUE3H/
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00049.html
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00050.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2Q4E3OTDAJRSUCOBTDQO7Y5UTE2FFMLF/
- https://access.redhat.com/errata/RHSA-2020:0222
- http://jvn.jp/en/jp/JVN52486659/index.html
- https://nvd.nist.gov/vuln/detail/CVE-2019-14869