CVE-2019-16201
CVE-2019-16201
This page contains facts from public vulnerability sources. Check the original advisory before updating.
WEBrick::HTTPAuth::DigestAuth in Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 has a regular expression Denial of Service cause by looping/backtracking. A victim must expose a WEBrick server that uses DigestAuth to the Internet or a untrusted network.
CVSS 7.5 · High · EPSS 5.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
jruby Debian:12
- Affected ranges
- ECOSYSTEM: < 9.3.9.0+ds-1
Update to 9.3.9.0+ds-1
jruby Debian:13
- Affected ranges
- ECOSYSTEM: < 9.3.9.0+ds-1
Update to 9.3.9.0+ds-1
jruby Debian:14
- Affected ranges
- ECOSYSTEM: < 9.3.9.0+ds-1
Update to 9.3.9.0+ds-1
jruby Ubuntu:Pro:14.04:LTS
- Versions
- 1.5.6-5ubuntu1
- 1.5.6-6
- 1.5.6-7
- Affected ranges
- ECOSYSTEM: < 1.5.6-9+deb8u2build0.14.04.1~esm2
Update to 1.5.6-9+deb8u2build0.14.04.1~esm2
ruby2.3 Ubuntu:16.04:LTS
- Versions
- 2.3.0-1
- 2.3.0-2
- 2.3.0-4ubuntu2
- 2.3.0-4ubuntu3
- 2.3.0-5ubuntu1
- 2.3.1-2~16.04
- 2.3.1-2~16.04.2
- 2.3.1-2~16.04.4
- 2.3.1-2~16.04.5
- 2.3.1-2~16.04.6
- 2.3.1-2~16.04.7
- 2.3.1-2~16.04.9
- 2.3.1-2~16.04.10
- 2.3.1-2~16.04.11
- 2.3.1-2~16.04.12
- 2.3.1-2~ubuntu16.04.13
- Affected ranges
- ECOSYSTEM: < 2.3.1-2~ubuntu16.04.14
Update to 2.3.1-2~ubuntu16.04.14
jruby Ubuntu:16.04:LTS
- Versions
- 1.7.21-2ubuntu4
- 1.7.22-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ruby2.5 Ubuntu:18.04:LTS
- Versions
- 2.5.0~preview1-1ubuntu2
- 2.5.0-4ubuntu1
- 2.5.0-4ubuntu4
- 2.5.0-5ubuntu1
- 2.5.0-6ubuntu1
- 2.5.1-1ubuntu1
- 2.5.1-1ubuntu1.1
- 2.5.1-1ubuntu1.2
- 2.5.1-1ubuntu1.4
- 2.5.1-1ubuntu1.5
- Affected ranges
- ECOSYSTEM: < 2.5.1-1ubuntu1.6
Update to 2.5.1-1ubuntu1.6
jruby Ubuntu:18.04:LTS
- Versions
- 9.1.13.0-1
- 9.1.17.0-1~18.04
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jruby Ubuntu:20.04:LTS
- Versions
- 9.1.17.0-3
- 9.1.17.0-3build5
- 9.1.17.0-3build6
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jruby Ubuntu:24.04:LTS
- Versions
- 9.3.9.0+ds-1
- 9.4.5.0+ds-1
- 9.4.5.0+ds-1ubuntu1
- 9.4.6.0+ds-1ubuntu3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jruby Ubuntu:25.10
- Versions
- 9.4.8.0+ds-2ubuntu1
- 9.4.8.0+ds-3ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jruby Ubuntu:26.10
- Versions
- 9.4.8.0+ds-3ubuntu1
- 9.4.14.0+ds-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
jruby Ubuntu:26.04:LTS
- Versions
- 9.4.8.0+ds-3ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://hackerone.com/reports/661722
- https://lists.debian.org/debian-lts-announce/2019/11/msg00025.html
- https://lists.debian.org/debian-lts-announce/2019/12/msg00009.html
- https://seclists.org/bugtraq/2019/Dec/31
- https://seclists.org/bugtraq/2019/Dec/32
- https://www.debian.org/security/2019/dsa-4587
- https://www.oracle.com/security-alerts/cpujan2020.html
- https://security.gentoo.org/glsa/202003-06
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00041.html
- https://lists.debian.org/debian-lts-announce/2020/08/msg00027.html
- https://lists.debian.org/debian-lts-announce/2023/04/msg00033.html
- https://nvd.nist.gov/vuln/detail/CVE-2019-16201