CVE-2019-16777
CVE-2019-16777 · Arbitrary File Overwrite in npm CLI
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Versions of the npm CLI prior to 6.13.4 are vulnerable to an Arbitrary File Overwrite. It fails to prevent existing globally-installed binaries to be overwritten by other package installations. For example, if a package was installed globally and created a serve binary, any subsequent installs of packages that also create a serve binary would overwrite the previous serve binary. This behavior is still allowed in local installations and also through install scripts. This vulnerability bypasses a user using the --ignore-scripts install option.
CVSS 7.7 · High · EPSS 2.1% · Fix available
- Published
- Updated
Affected products and versions
cli
- Versions
- ≥ < 6.13.4, < 6.13.4: Affected (custom)
No fix published
npm Debian:12
- Affected ranges
- ECOSYSTEM: < 6.13.4+ds-2
Update to 6.13.4+ds-2
npm Debian:13
- Affected ranges
- ECOSYSTEM: < 6.13.4+ds-2
Update to 6.13.4+ds-2
npm Debian:14
- Affected ranges
- ECOSYSTEM: < 6.13.4+ds-2
Update to 6.13.4+ds-2
npm npm
- Affected ranges
- SEMVER: < 6.13.4
Update to 6.13.4
npm Ubuntu:14.04:LTS
- Versions
- 1.2.18~dfsg-3
- 1.3.10~dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
npm Ubuntu:Pro:16.04:LTS
- Versions
- 1.4.21+ds-2
- 3.5.2-0ubuntu4
- 3.5.2-0ubuntu4.1.16.04.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
npm Ubuntu:Pro:18.04:LTS
- Versions
- 3.5.2-0ubuntu4
- 3.5.2-0ubuntu4.1.18.04.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
npm Ubuntu:20.04:LTS
- Versions
- 5.8.0+ds6-4
- 6.14.4+ds-1ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
npm Ubuntu:22.04:LTS
- Versions
- 7.5.2+ds-2
- 7.24.2+ds-1
- 7.24.2+ds-2
- 8.3.0~ds-1
- 8.3.0~ds-2
- 8.3.2~ds-1
- 8.5.0~ds-1
- 8.5.1~ds-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
npm Ubuntu:24.04:LTS
- Versions
- 9.2.0~ds1-1
- 9.2.0~ds1-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
npm Ubuntu:25.10
- Versions
- 9.2.0~ds1-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
npm Ubuntu:26.10
- Versions
- 9.2.0~ds3-1
- 11.16.0+ds2-4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
npm Ubuntu:26.04:LTS
- Versions
- 9.2.0~ds1-3
- 9.2.0~ds2-2
- 9.2.0~ds3-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://blog.npmjs.org/post/189618601100/binary-planting-with-the-npm-cli
- https://github.com/npm/cli/security/advisories/GHSA-4328-8hgf-7wjr
- https://www.oracle.com/security-alerts/cpujan2020.html
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00027.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/Z36UKPO5F3PQ3Q2POMF5LEKXWAH5RUFP/
- https://access.redhat.com/errata/RHEA-2020:0330
- https://access.redhat.com/errata/RHSA-2020:0573
- https://access.redhat.com/errata/RHSA-2020:0579
- https://access.redhat.com/errata/RHSA-2020:0597
- https://access.redhat.com/errata/RHSA-2020:0602
- https://security.gentoo.org/glsa/202003-48
- https://nvd.nist.gov/vuln/detail/CVE-2019-16777