p PatchFirst

CVE-2019-17543

CVE-2019-17543

This page contains facts from public vulnerability sources. Check the original advisory before updating.

LZ4 before 1.9.2 has a heap-based buffer overflow in LZ4_write32 (related to LZ4_compress_destSize), affecting applications that call LZ4_compress_fast with a large input. (This issue can also lead to data corruption.) NOTE: the vendor states "only a few specific / uncommon usages of the API are at risk."

CVSS 8.1 · High · EPSS 10.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • lz4 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.9.2-1

    Update to 1.9.2-1

  • lz4 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.9.2-1

    Update to 1.9.2-1

  • lz4 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.9.2-1

    Update to 1.9.2-1

Original sources

Check your server →