p PatchFirst

PatchFirst · Latest vulnerabilities

lz4 vulnerabilities

Vulnerabilities published for lz4 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2021-3520

    Critical · CVSS 9.8EPSS 3.4%Fix available

    CVE-2021-3520

    There's a flaw in lz4. An attacker who submits a crafted file to an application linked with lz4 may be able to trigger an integer overflow, leading to calling of memmove() on a negative size argument, causing an out-of-bounds write and/or a crash. The greatest impact of this flaw is to availability, with some potential impact to confidentiality and integrity as well.

    • Update to 1.9.3-2
    Published Updated
  2. CVE-2019-17543

    High · CVSS 8.1EPSS 10.45%Fix available

    CVE-2019-17543

    LZ4 before 1.9.2 has a heap-based buffer overflow in LZ4_write32 (related to LZ4_compress_destSize), affecting applications that call LZ4_compress_fast with a large input. (This issue can also lead to data corruption.) NOTE: the vendor states "only a few specific / uncommon usages of the API are at risk."

    • Update to 1.9.2-1
    Published Updated
  3. CVE-2014-4715

    Not ratedEPSS 2.75%Fix available

    CVE-2014-4715

    Yann Collet LZ4 before r119, when used on certain 32-bit platforms that allocate memory beyond 0x80000000, does not properly detect integer overflows, which allows context-dependent attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via a crafted Literal Run, a different vulnerability than CVE-2014-4611.

    • Update to 0.0~r119-1
    Published Updated
  4. CVE-2014-4611

    Not ratedEPSS 8.87%Fix available

    CVE-2014-4611

    Integer overflow in the LZ4 algorithm implementation, as used in Yann Collet LZ4 before r118 and in the lz4_uncompress function in lib/lz4/lz4_decompress.c in the Linux kernel before 3.15.2, on 32-bit platforms might allow context-dependent attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via a crafted Literal Run that would be improperly handled by programs not complying with an API limitation, a different vulnerability than CVE-2014-4715.

    • Update to 0.0~r119-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →