p PatchFirst

CVE-2019-19609

CVE-2019-19609

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The Strapi framework before 3.0.0-beta.17.8 is vulnerable to Remote Code Execution in the Install and Uninstall Plugin components of the Admin panel, because it does not sanitize the plugin name, and attackers can inject arbitrary shell commands to be executed by the execa function.

CVSS 7.2 · High · EPSS 54.1% · Public exploit · Fix available

Published
Updated

Stack: node

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • strapi npm

    Affected ranges
    • SEMVER: < 3.0.0-beta.17.8

    Update to 3.0.0-beta.17.8

Original sources

Check your server →