p PatchFirst

PatchFirst · Latest vulnerabilities

strapi vulnerabilities

Vulnerabilities published for strapi in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 12

  1. CVE-2022-29894

    Medium · CVSS 4.8EPSS 0.77%No fix published

    CVE-2022-29894

    Strapi v3.x.x versions and earlier contain a stored cross-site scripting vulnerability in file upload function. By exploiting this vulnerability, an arbitrary script may be executed on the web browser of the user who is logging in to the product with the administrative privilege.

    Published Updated
  2. CVE-2022-30618

    High · CVSS 7.5EPSS 0.96%Fix available

    CVE-2022-30618

    An authenticated user with access to the Strapi admin panel can view private and sensitive data, such as email and password reset tokens, for API users if content types accessible to the authenticated user contain relationships to API users (from:users-permissions). There are many scenarios in which such details from API users can leak in the JSON response within the admin panel, either through a direct or indirect relationship. Access to this information enables a user to compromise these users’ accounts if the password reset API endpoints have been enabled. In a worst-case scenario, a low-privileged user could get access to a high-privilege

    • Update to 3.6.9
    Published Updated
  3. CVE-2022-30617

    High · CVSS 8.8EPSS 1.47%Fix available

    CVE-2022-30617

    An authenticated user with access to the Strapi admin panel can view private and sensitive data, such as email and password reset tokens, for other admin panel users that have a relationship (e.g., created by, updated by) with content accessible to the authenticated user. For example, a low-privileged “author” role account can view these details in the JSON response for an “editor” or “super admin” that has updated one of the author’s blog posts. There are also many other scenarios where such details from other users can leak in the JSON response, either through a direct or indirect relationship. Access to this information enables a user to c

    • Update to 3.6.9
    Published Updated
  4. CVE-2021-46440

    High · CVSS 7.5EPSS 2.88%Fix available

    CVE-2021-46440

    Storing passwords in a recoverable format in the DOCUMENTATION plugin component of Strapi before 3.6.9 and 4.x before 4.1.5 allows an attacker to access a victim's HTTP request, get the victim's cookie, perform a base64 decode on the victim's cookie, and obtain a cleartext password, leading to getting API documentation for further API attacks.

    • Update to 3.6.9
    Published Updated
  5. CVE-2020-13961

    Medium · CVSS 6.5EPSS 1.67%Fix available

    CVE-2020-13961

    Strapi before 3.0.2 could allow a remote authenticated attacker to bypass security restrictions because templates are stored in a global variable without any sanitation. By sending a specially crafted request, an attacker could exploit this vulnerability to update the email template for both password reset and account confirmation emails.

    • Update to 3.0.2
    Published Updated
  6. CVE-2019-19609

    High · CVSS 7.2EPSS 54.08%Public exploitFix available

    CVE-2019-19609

    The Strapi framework before 3.0.0-beta.17.8 is vulnerable to Remote Code Execution in the Install and Uninstall Plugin components of the Admin panel, because it does not sanitize the plugin name, and attackers can inject arbitrary shell commands to be executed by the execa function.

    • Update to 3.0.0-beta.17.8
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →