p PatchFirst

CVE-2019-20838

CVE-2019-20838

This page contains facts from public vulnerability sources. Check the original advisory before updating.

libpcre in PCRE before 8.43 allows a subject buffer over-read in JIT when UTF is disabled, and \X or \R has more than one fixed quantifier, a related issue to CVE-2019-20454.

CVSS 7.5 · High · EPSS 2.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • pcre3 Debian:12

    Versions
    • 2:8.39-15
    • 2:8.39-15.1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • pcre3 Ubuntu:18.04:LTS

    Versions
    • 2:8.39-5ubuntu3
    • 2:8.39-8
    • 2:8.39-9
    Affected ranges
    • ECOSYSTEM: < 2:8.39-9ubuntu0.1

    Update to 2:8.39-9ubuntu0.1

  • pcre3 Ubuntu:20.04:LTS

    Versions
    • 2:8.39-12
    • 2:8.39-12build1
    Affected ranges
    • ECOSYSTEM: < 2:8.39-12ubuntu0.1

    Update to 2:8.39-12ubuntu0.1

  • pcre3 Ubuntu:22.04:LTS

    Versions
    • 2:8.39-13build3
    • 2:8.39-13build4
    • 2:8.39-13build5
    Affected ranges
    • ECOSYSTEM: < 2:8.39-13ubuntu0.22.04.1

    Update to 2:8.39-13ubuntu0.22.04.1

  • pcre3 Ubuntu:24.04:LTS

    Versions
    • 2:8.39-15
    • 2:8.39-15build1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • pcre3 Ubuntu:25.10

    Versions
    • 2:8.39-15.1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →