CVE-2019-20925
CVE-2019-20925 · Denial of service via malformed network packet
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An unauthenticated client can trigger denial of service by issuing specially crafted wire protocol messages, which cause the message decompressor to incorrectly allocate memory. This issue affects MongoDB Server v4.2 versions prior to 4.2.1; MongoDB Server v4.0 versions prior to 4.0.13; MongoDB Server v3.6 versions prior to 3.6.15 and MongoDB Server v3.4 versions prior to 3.4.24.
CVSS 7.5 · High · EPSS 1.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
mongodb server
- Versions
- ≥ 4.2, < 4.2.1: Affected (custom)
- ≥ 4.0, < 4.0.13: Affected (custom)
- ≥ 3.6, < 3.6.15: Affected (custom)
- ≥ 3.4, < 3.4.24: Affected (custom)
Update to 3.4.24; Update to 3.6.15; Update to 4.0.13; Update to 4.2.1
mongodb Ubuntu:18.04:LTS
- Versions
- 1:3.4.7-1
- 1:3.4.7-1ubuntu1
- 1:3.4.7-1ubuntu2
- 1:3.4.7-1ubuntu4
- 1:3.4.14-3ubuntu1
- 1:3.4.14-3ubuntu2
- 1:3.6.3-0ubuntu1
- 1:3.6.3-0ubuntu1.1
- 1:3.6.3-0ubuntu1.3
- Affected ranges
- ECOSYSTEM: < 1:3.6.3-0ubuntu1.4
Update to 1:3.6.3-0ubuntu1.4
mongodb Ubuntu:20.04:LTS
- Versions
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu2
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.2
- Affected ranges
- ECOSYSTEM: < 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3
Update to 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3