p PatchFirst

PatchFirst · Latest vulnerabilities

mongodb vulnerabilities

Vulnerabilities published for mongodb in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2019-20925

    High · CVSS 7.5EPSS 1.68%Fix available

    Denial of service via malformed network packet

    An unauthenticated client can trigger denial of service by issuing specially crafted wire protocol messages, which cause the message decompressor to incorrectly allocate memory. This issue affects MongoDB Server v4.2 versions prior to 4.2.1; MongoDB Server v4.0 versions prior to 4.0.13; MongoDB Server v3.6 versions prior to 3.6.15 and MongoDB Server v3.4 versions prior to 3.4.24.

    • Update to 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3
    Published Updated
  2. CVE-2019-2386

    High · CVSS 7.1EPSS 1.14%Fix available

    Authorization session conflation

    After user deletion in MongoDB Server the improper invalidation of authorization sessions allows an authenticated user's session to persist and become conflated with new accounts, if those accounts reuse the names of deleted ones. This issue affects MongoDB Server v4.0 versions prior to 4.0.9; MongoDB Server v3.6 versions prior to 3.6.13 and MongoDB Server v3.4 versions prior to 3.4.22. Workaround: After deleting one or more users, restart any nodes which may have had active user authorization sessions. Refrain from creating user accounts with the same name as previously deleted accounts.

    • Update to 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →