CVE-2019-5815
CVE-2019-5815
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Type confusion in xsltNumberFormatGetMultipleLevel prior to libxslt 1.1.33 could allow attackers to potentially exploit heap corruption via crafted XML data.
CVSS 7.5 · High · EPSS 1.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
chrome
- Versions
- ≥ unspecified, < 74.0.3729.108: Affected (custom)
Update to 74.0.3729.108
chromium Debian:12
- Affected ranges
- ECOSYSTEM: < 74.0.3729.108-1
Update to 74.0.3729.108-1
chromium Debian:13
- Affected ranges
- ECOSYSTEM: < 74.0.3729.108-1
Update to 74.0.3729.108-1
chromium Debian:14
- Affected ranges
- ECOSYSTEM: < 74.0.3729.108-1
Update to 74.0.3729.108-1
libxslt Debian:12
- Affected ranges
- ECOSYSTEM: < 1.1.34-2
Update to 1.1.34-2
libxslt Debian:13
- Affected ranges
- ECOSYSTEM: < 1.1.34-2
Update to 1.1.34-2
libxslt Debian:14
- Affected ranges
- ECOSYSTEM: < 1.1.34-2
Update to 1.1.34-2
libxslt Ubuntu:Pro:14.04:LTS
- Versions
- 1.1.28-2
- 1.1.28-2build1
- 1.1.28-2ubuntu0.1
- 1.1.28-2ubuntu0.2
- 1.1.28-2ubuntu0.2+esm1
- Affected ranges
- ECOSYSTEM: < 1.1.28-2ubuntu0.2+esm2
Update to 1.1.28-2ubuntu0.2+esm2
libxslt Ubuntu:Pro:16.04:LTS
- Versions
- 1.1.28-2build2
- 1.1.28-2.1
- 1.1.28-2.1ubuntu0.1
- 1.1.28-2.1ubuntu0.2
- 1.1.28-2.1ubuntu0.3
- Affected ranges
- ECOSYSTEM: < 1.1.28-2.1ubuntu0.3+esm1
Update to 1.1.28-2.1ubuntu0.3+esm1
libxslt Ubuntu:18.04:LTS
- Versions
- 1.1.29-2.1ubuntu1
- 1.1.29-4
- 1.1.29-5
- 1.1.29-5ubuntu0.1
- 1.1.29-5ubuntu0.2
- Affected ranges
- ECOSYSTEM: < 1.1.29-5ubuntu0.3
Update to 1.1.29-5ubuntu0.3