p PatchFirst

CVE-2019-9499

CVE-2019-9499 · The implementations of EAP-PWD in wpa_supplicant EAP Peer do not validate the scalar and element values in EAP-pwd-Commit

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The implementations of EAP-PWD in wpa_supplicant EAP Peer, when built against a crypto library missing explicit validation on imported elements, do not validate the scalar and element values in EAP-pwd-Commit. An attacker may complete authentication, session key and control of the data connection with a client. Both hostapd with SAE support and wpa_supplicant with SAE support prior to and including version 2.4 are affected. Both hostapd with EAP-pwd support and wpa_supplicant with EAP-pwd support prior to and including version 2.7 are affected.

CVSS 8.1 · High · EPSS 2.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • hostapd with eap-pwd support

    Versions
    • ≥ 2.7, ≤ 2.7: Affected (custom)

    No fix published

  • wpa_supplicant with eap-pwd support

    Versions
    • ≥ 2.7, ≤ 2.7: Affected (custom)

    No fix published

  • hostapd with sae support

    Versions
    • ≥ 2.4, ≤ 2.4: Affected (custom)

    No fix published

  • wpa_supplicant with sae support

    Versions
    • ≥ 2.4, ≤ 2.4: Affected (custom)

    No fix published

  • wpa Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:2.7+git20190128+0c1e29f-4

    Update to 2:2.7+git20190128+0c1e29f-4

  • wpa Debian:13

    Affected ranges
    • ECOSYSTEM: < 2:2.7+git20190128+0c1e29f-4

    Update to 2:2.7+git20190128+0c1e29f-4

  • wpa Debian:14

    Affected ranges
    • ECOSYSTEM: < 2:2.7+git20190128+0c1e29f-4

    Update to 2:2.7+git20190128+0c1e29f-4

  • wpa Ubuntu:14.04:LTS

    Versions
    • 1.0-3ubuntu2
    • 1.0-3ubuntu3
    • 1.0-3ubuntu4
    • 2.1-0ubuntu1
    • 2.1-0ubuntu1.1
    • 2.1-0ubuntu1.2
    • 2.1-0ubuntu1.3
    • 2.1-0ubuntu1.4
    • 2.1-0ubuntu1.5
    • 2.1-0ubuntu1.6
    Affected ranges
    • ECOSYSTEM: < 2.1-0ubuntu1.7

    Update to 2.1-0ubuntu1.7

  • wpa Ubuntu:16.04:LTS

    Versions
    • 2.4-0ubuntu3
    • 2.4-0ubuntu4
    • 2.4-0ubuntu5
    • 2.4-0ubuntu6
    • 2.4-0ubuntu6.2
    • 2.4-0ubuntu6.3
    Affected ranges
    • ECOSYSTEM: < 2.4-0ubuntu6.4

    Update to 2.4-0ubuntu6.4

  • wpa Ubuntu:18.04:LTS

    Versions
    • 2.4-0ubuntu10
    • 2:2.4-1.1ubuntu1
    • 2:2.6-15ubuntu1
    • 2:2.6-15ubuntu2
    • 2:2.6-15ubuntu2.1
    Affected ranges
    • ECOSYSTEM: < 2:2.6-15ubuntu2.2

    Update to 2:2.6-15ubuntu2.2

Original sources

Check your server →