p PatchFirst

CVE-2020-10029

CVE-2020-10029

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The GNU C Library (aka glibc or libc6) before 2.32 could overflow an on-stack buffer during range reduction if an input to an 80-bit long double function contains a non-canonical bit pattern, a seen when passing a 0x5d414141414141410000 value to sinl on x86 targets. This is related to sysdeps/ieee754/ldbl-96/e_rem_pio2l.c.

CVSS 5.5 · Medium · EPSS 0.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • glibc Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.30-1

    Update to 2.30-1

  • glibc Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.30-1

    Update to 2.30-1

  • glibc Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.30-1

    Update to 2.30-1

  • eglibc Ubuntu:Pro:14.04:LTS

    Versions
    • 2.17-93ubuntu4
    • 2.18-0ubuntu1
    • 2.18-0ubuntu2
    • 2.18-0ubuntu4
    • 2.18-0ubuntu5
    • 2.18-0ubuntu6
    • 2.18-0ubuntu7
    • 2.19-0ubuntu2
    • 2.19-0ubuntu3
    • 2.19-0ubuntu4
    • 2.19-0ubuntu5
    • 2.19-0ubuntu6
    • 2.19-0ubuntu6.1
    • 2.19-0ubuntu6.3
    • 2.19-0ubuntu6.4
    • 2.19-0ubuntu6.5
    • 2.19-0ubuntu6.6
    • 2.19-0ubuntu6.7
    • 2.19-0ubuntu6.8
    • 2.19-0ubuntu6.9
    • 2.19-0ubuntu6.10
    • 2.19-0ubuntu6.11
    • 2.19-0ubuntu6.13
    • 2.19-0ubuntu6.14
    • 2.19-0ubuntu6.15
    • 2.19-0ubuntu6.15+esm1
    • 2.19-0ubuntu6.15+esm2
    • 2.19-0ubuntu6.15+esm3
    • 2.19-0ubuntu6.15+esm4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • glibc Ubuntu:16.04:LTS

    Versions
    • 2.21-0ubuntu4
    • 2.21-0ubuntu5
    • 2.21-0ubuntu6
    • 2.23-0ubuntu1
    • 2.23-0ubuntu2
    • 2.23-0ubuntu3
    • 2.23-0ubuntu4
    • 2.23-0ubuntu5
    • 2.23-0ubuntu6
    • 2.23-0ubuntu7
    • 2.23-0ubuntu9
    • 2.23-0ubuntu10
    • 2.23-0ubuntu11
    Affected ranges
    • ECOSYSTEM: < 2.23-0ubuntu11.2

    Update to 2.23-0ubuntu11.2

  • glibc Ubuntu:18.04:LTS

    Versions
    • 2.26-0ubuntu2
    • 2.26-0ubuntu2.1
    • 2.27-0ubuntu2
    • 2.27-0ubuntu3
    • 2.27-3ubuntu1
    Affected ranges
    • ECOSYSTEM: < 2.27-3ubuntu1.2

    Update to 2.27-3ubuntu1.2

Original sources

Check your server →