p PatchFirst

CVE-2020-14155

CVE-2020-14155

This page contains facts from public vulnerability sources. Check the original advisory before updating.

libpcre in PCRE before 8.44 allows an integer overflow via a large number after a (?C substring.

CVSS 5.3 · Medium · EPSS 4.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • pcre3 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:8.39-13

    Update to 2:8.39-13

  • pcre3 Ubuntu:Pro:14.04:LTS

    Versions
    • 1:8.31-2
    • 1:8.31-2ubuntu2
    • 1:8.31-2ubuntu2.1
    • 1:8.31-2ubuntu2.2
    • 1:8.31-2ubuntu2.3
    Affected ranges
    • ECOSYSTEM: < 1:8.31-2ubuntu2.3+esm1

    Update to 1:8.31-2ubuntu2.3+esm1

  • pcre3 Ubuntu:Pro:16.04:LTS

    Versions
    • 2:8.35-7.1ubuntu1
    • 2:8.38-1ubuntu1
    • 2:8.38-3
    • 2:8.38-3.1
    Affected ranges
    • ECOSYSTEM: < 2:8.38-3.1ubuntu0.1~esm1

    Update to 2:8.38-3.1ubuntu0.1~esm1

  • pcre3 Ubuntu:18.04:LTS

    Versions
    • 2:8.39-5ubuntu3
    • 2:8.39-8
    • 2:8.39-9
    Affected ranges
    • ECOSYSTEM: < 2:8.39-9ubuntu0.1

    Update to 2:8.39-9ubuntu0.1

  • pcre3 Ubuntu:20.04:LTS

    Versions
    • 2:8.39-12
    • 2:8.39-12build1
    Affected ranges
    • ECOSYSTEM: < 2:8.39-12ubuntu0.1

    Update to 2:8.39-12ubuntu0.1

Original sources

Check your server →