CVE-2020-15244
CVE-2020-15244 · RCE in Magento
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Magento (rubygems openmage/magento-lts package) before versions 19.4.8 and 20.0.4, an admin user can generate soap credentials that can be used to trigger RCE via PHP Object Injection through product attributes and a product. The issue is patched in versions 19.4.8 and 20.0.4.
CVSS 8.0 · High · EPSS 1.3% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
magento-lts
- Versions
- < 19.4.8: Affected
- >= 20.0.0, < 20.0.4: Affected
No fix published
openmage/magento-lts Packagist
- Versions
- 1.9.1.1
- 1.9.2.0
- 1.9.2.1
- 1.9.2.2
- 1.9.2.3
- 1.9.2.4
- 1.9.3.0
- 1.9.3.1
- v19.4.0
- v19.4.1
- v19.4.2
- v19.4.3
- v19.4.4
- v19.4.5
- v19.4.6
- v19.4.7
- Affected ranges
- ECOSYSTEM: < 19.4.8
Update to 19.4.8
openmage/magento-lts Packagist
- Versions
- v20.0.0
- v20.0.1
- v20.0.2
- v20.0.3
- Affected ranges
- ECOSYSTEM: ≥ 20.0.0, < 20.0.4
Update to 20.0.4