p PatchFirst

CVE-2020-1751

CVE-2020-1751

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An out-of-bounds write vulnerability was found in glibc before 2.31 when handling signal trampolines on PowerPC. Specifically, the backtrace function did not properly check the array bounds when storing the frame address, resulting in a denial of service or potential code execution. The highest threat from this vulnerability is to system availability.

CVSS 5.1 · Medium · EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • glibc

    Versions
    • 2.31: Affected

    No fix published

  • glibc Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.30-3

    Update to 2.30-3

  • glibc Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.30-3

    Update to 2.30-3

  • glibc Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.30-3

    Update to 2.30-3

  • eglibc Ubuntu:Pro:14.04:LTS

    Versions
    • 2.17-93ubuntu4
    • 2.18-0ubuntu1
    • 2.18-0ubuntu2
    • 2.18-0ubuntu4
    • 2.18-0ubuntu5
    • 2.18-0ubuntu6
    • 2.18-0ubuntu7
    • 2.19-0ubuntu2
    • 2.19-0ubuntu3
    • 2.19-0ubuntu4
    • 2.19-0ubuntu5
    • 2.19-0ubuntu6
    • 2.19-0ubuntu6.1
    • 2.19-0ubuntu6.3
    • 2.19-0ubuntu6.4
    • 2.19-0ubuntu6.5
    • 2.19-0ubuntu6.6
    • 2.19-0ubuntu6.7
    • 2.19-0ubuntu6.8
    • 2.19-0ubuntu6.9
    • 2.19-0ubuntu6.10
    • 2.19-0ubuntu6.11
    • 2.19-0ubuntu6.13
    • 2.19-0ubuntu6.14
    • 2.19-0ubuntu6.15
    • 2.19-0ubuntu6.15+esm1
    • 2.19-0ubuntu6.15+esm2
    • 2.19-0ubuntu6.15+esm3
    • 2.19-0ubuntu6.15+esm4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • glibc Ubuntu:16.04:LTS

    Versions
    • 2.21-0ubuntu4
    • 2.21-0ubuntu5
    • 2.21-0ubuntu6
    • 2.23-0ubuntu1
    • 2.23-0ubuntu2
    • 2.23-0ubuntu3
    • 2.23-0ubuntu4
    • 2.23-0ubuntu5
    • 2.23-0ubuntu6
    • 2.23-0ubuntu7
    • 2.23-0ubuntu9
    • 2.23-0ubuntu10
    • 2.23-0ubuntu11
    Affected ranges
    • ECOSYSTEM: < 2.23-0ubuntu11.2

    Update to 2.23-0ubuntu11.2

  • glibc Ubuntu:18.04:LTS

    Versions
    • 2.26-0ubuntu2
    • 2.26-0ubuntu2.1
    • 2.27-0ubuntu2
    • 2.27-0ubuntu3
    • 2.27-3ubuntu1
    Affected ranges
    • ECOSYSTEM: < 2.27-3ubuntu1.2

    Update to 2.27-3ubuntu1.2

Original sources

Check your server →