p PatchFirst

CVE-2020-1968

CVE-2020-1968 · Raccoon attack

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The Raccoon attack exploits a flaw in the TLS specification which can lead to an attacker being able to compute the pre-master secret in connections which have used a Diffie-Hellman (DH) based ciphersuite. In such a case this would result in the attacker being able to eavesdrop on all encrypted communications sent over that TLS connection. The attack can only be exploited if an implementation re-uses a DH secret across multiple TLS connections. Note that this issue only impacts DH ciphersuites and not ECDH ciphersuites. This issue affects OpenSSL 1.0.2 which is out of support and no longer receiving public updates. OpenSSL 1.1.1 is not vulnerable to this issue. Fixed in OpenSSL 1.0.2w (Affected 1.0.2-1.0.2v).

CVSS 3.7 · Low · EPSS 4.9% · Fix available

Published
Updated

Stack: system · network

Affected products and versions

  • openssl

    Versions
    • Fixed in OpenSSL 1.0.2w (Affected 1.0.2-1.0.2v): Affected

    No fix published

  • openssl Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.1.0c-1

    Update to 1.1.0c-1

  • openssl Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.1.0c-1

    Update to 1.1.0c-1

  • openssl Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.1.0c-1

    Update to 1.1.0c-1

  • openssl Ubuntu:Pro:14.04:LTS

    Versions
    • 1.0.1e-3ubuntu1
    • 1.0.1e-4ubuntu1
    • 1.0.1e-4ubuntu2
    • 1.0.1e-4ubuntu3
    • 1.0.1e-4ubuntu4
    • 1.0.1f-1ubuntu1
    • 1.0.1f-1ubuntu2
    • 1.0.1f-1ubuntu2.1
    • 1.0.1f-1ubuntu2.2
    • 1.0.1f-1ubuntu2.3
    • 1.0.1f-1ubuntu2.4
    • 1.0.1f-1ubuntu2.5
    • 1.0.1f-1ubuntu2.7
    • 1.0.1f-1ubuntu2.8
    • 1.0.1f-1ubuntu2.11
    • 1.0.1f-1ubuntu2.12
    • 1.0.1f-1ubuntu2.15
    • 1.0.1f-1ubuntu2.16
    • 1.0.1f-1ubuntu2.17
    • 1.0.1f-1ubuntu2.18
    • 1.0.1f-1ubuntu2.19
    • 1.0.1f-1ubuntu2.20
    • 1.0.1f-1ubuntu2.21
    • 1.0.1f-1ubuntu2.22
    • 1.0.1f-1ubuntu2.23
    • 1.0.1f-1ubuntu2.24
    • 1.0.1f-1ubuntu2.25
    • 1.0.1f-1ubuntu2.26
    • 1.0.1f-1ubuntu2.27
    • 1.0.1f-1ubuntu2.27+esm1
    • 1.0.1f-1ubuntu2.27+esm2
    • 1.0.1f-1ubuntu2.27+esm3
    • 1.0.1f-1ubuntu2.27+esm4
    • 1.0.1f-1ubuntu2.27+esm5
    • 1.0.1f-1ubuntu2.27+esm6
    • 1.0.1f-1ubuntu2.27+esm7
    • 1.0.1f-1ubuntu2.27+esm9
    Affected ranges
    • ECOSYSTEM: < 1.0.1f-1ubuntu2.27+esm10

    Update to 1.0.1f-1ubuntu2.27+esm10

  • openssl Ubuntu:16.04:LTS

    Versions
    • 1.0.2d-0ubuntu1
    • 1.0.2d-0ubuntu2
    • 1.0.2e-1ubuntu1
    • 1.0.2f-2ubuntu1
    • 1.0.2g-1ubuntu2
    • 1.0.2g-1ubuntu3
    • 1.0.2g-1ubuntu4
    • 1.0.2g-1ubuntu4.1
    • 1.0.2g-1ubuntu4.2
    • 1.0.2g-1ubuntu4.4
    • 1.0.2g-1ubuntu4.5
    • 1.0.2g-1ubuntu4.6
    • 1.0.2g-1ubuntu4.8
    • 1.0.2g-1ubuntu4.9
    • 1.0.2g-1ubuntu4.10
    • 1.0.2g-1ubuntu4.11
    • 1.0.2g-1ubuntu4.12
    • 1.0.2g-1ubuntu4.13
    • 1.0.2g-1ubuntu4.14
    • 1.0.2g-1ubuntu4.15
    • 1.0.2g-1ubuntu4.16
    Affected ranges
    • ECOSYSTEM: < 1.0.2g-1ubuntu4.17

    Update to 1.0.2g-1ubuntu4.17

  • edk2 Ubuntu:Pro:16.04:LTS

    Versions
    • 0~20150106.5c2d456b-2
    • 0~20160104.c2a892d7-1
    • 0~20160408.ffea0a2c-2
    • 0~20160408.ffea0a2c-2ubuntu0.1
    • 0~20160408.ffea0a2c-2ubuntu0.2
    • 0~20160408.ffea0a2c-2ubuntu0.2+esm1
    • 0~20160408.ffea0a2c-2ubuntu0.2+esm3
    • 0~20160408.ffea0a2c-2ubuntu0.2+esm4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • openssl Ubuntu:Pro:FIPS-updates:16.04:LTS

    Versions
    • 1.0.2g-1ubuntu4.fips.4.9.1
    • 1.0.2g-1ubuntu4.fips.4.13.1
    • 1.0.2g-1ubuntu4.fips.4.15.1
    • 1.0.2g-1ubuntu4.fips.4.16.1
    Affected ranges
    • ECOSYSTEM: < 1.0.2g-1ubuntu4.fips.4.17.1

    Update to 1.0.2g-1ubuntu4.fips.4.17.1

  • openssl Ubuntu:Pro:FIPS:16.04:LTS

    Versions
    • 1.0.2g-1ubuntu4.fips.4.6~ppa1
    • 1.0.2g-1ubuntu4.fips.4.6~ppa2
    • 1.0.2g-1ubuntu4.fips.4.6~ppa3
    • 1.0.2g-1ubuntu4.fips.4.6
    • 1.0.2g-1ubuntu4.fips.4.6.1
    • 1.0.2g-1ubuntu4.fips.4.6.2
    • 1.0.2g-1ubuntu4.fips.4.6.3
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • openssl1.0 Ubuntu:18.04:LTS

    Versions
    • 1.0.2n-1ubuntu2
    • 1.0.2n-1ubuntu3
    • 1.0.2n-1ubuntu4
    • 1.0.2n-1ubuntu5
    • 1.0.2n-1ubuntu5.1
    • 1.0.2n-1ubuntu5.2
    • 1.0.2n-1ubuntu5.3
    Affected ranges
    • ECOSYSTEM: < 1.0.2n-1ubuntu5.4

    Update to 1.0.2n-1ubuntu5.4

Original sources

Check your server →