p PatchFirst

CVE-2020-22219

CVE-2020-22219

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Buffer Overflow vulnerability in function bitwriter_grow_ in flac before 1.4.0 allows remote attackers to run arbitrary code via crafted input to the encoder.

CVSS 7.8 · High · EPSS 0.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • flac Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.4.1-1

    Update to 1.4.1-1

  • flac Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.4.1-1

    Update to 1.4.1-1

  • flac Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.4.1-1

    Update to 1.4.1-1

  • flac Ubuntu:Pro:14.04:LTS

    Versions
    • 1.3.0-1
    • 1.3.0-2
    • 1.3.0-2ubuntu0.14.04.1
    • 1.3.0-2ubuntu0.14.04.1+esm1
    Affected ranges
    • ECOSYSTEM: < 1.3.0-2ubuntu0.14.04.1+esm2

    Update to 1.3.0-2ubuntu0.14.04.1+esm2

  • flac Ubuntu:Pro:16.04:LTS

    Versions
    • 1.3.1-4
    • 1.3.1-4ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: < 1.3.1-4ubuntu0.1~esm2

    Update to 1.3.1-4ubuntu0.1~esm2

  • flac Ubuntu:Pro:18.04:LTS

    Versions
    • 1.3.2-1
    • 1.3.2-1ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 1.3.2-1ubuntu0.1+esm1

    Update to 1.3.2-1ubuntu0.1+esm1

  • flac Ubuntu:20.04:LTS

    Versions
    • 1.3.3-1
    • 1.3.3-1build1
    • 1.3.3-1ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 1.3.3-1ubuntu0.2

    Update to 1.3.3-1ubuntu0.2

  • flac Ubuntu:22.04:LTS

    Versions
    • 1.3.3-2
    • 1.3.3-2build1
    • 1.3.3-2build2
    • 1.3.3-2ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 1.3.3-2ubuntu0.2

    Update to 1.3.3-2ubuntu0.2

Original sources

Check your server →