CVE-2020-24916
CVE-2020-24916
This page contains facts from public vulnerability sources. Check the original advisory before updating.
CGI implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to OS command injection.
CVSS 9.8 · Critical · EPSS 17.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
yaws Debian:12
- Affected ranges
- ECOSYSTEM: < 2.0.8+dfsg-1
Update to 2.0.8+dfsg-1
yaws Debian:13
- Affected ranges
- ECOSYSTEM: < 2.0.8+dfsg-1
Update to 2.0.8+dfsg-1
yaws Debian:14
- Affected ranges
- ECOSYSTEM: < 2.0.8+dfsg-1
Update to 2.0.8+dfsg-1
yaws Ubuntu:16.04:LTS
- Versions
- 1.98-5
- 1.99-1
- 1.99-2
- 2.0.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
yaws Ubuntu:18.04:LTS
- Versions
- 2.0.4+dfsg-2
- Affected ranges
- ECOSYSTEM: < 2.0.4+dfsg-2ubuntu0.1
Update to 2.0.4+dfsg-2ubuntu0.1
yaws Ubuntu:20.04:LTS
- Versions
- 2.0.6+dfsg-1
- 2.0.6+dfsg-3
- 2.0.7+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/erlyaws/yaws/commits/master
- https://packetstormsecurity.com/files/159106/Yaws-2.0.7-XML-Injection-Command-Injection.html
- https://vuln.be/post/yaws-xxe-and-shell-injections/
- https://github.com/vulnbe/poc-yaws-cgi-shell-injection
- https://lists.debian.org/debian-lts-announce/2020/09/msg00022.html
- https://usn.ubuntu.com/4569-1/
- https://www.debian.org/security/2020/dsa-4773
- https://nvd.nist.gov/vuln/detail/CVE-2020-24916