CVE-2020-24916
CGI implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to OS command injection.
- Update to 2.0.4+dfsg-2ubuntu0.1
PatchFirst · Latest vulnerabilities
Vulnerabilities published for yaws in the last 30 days: 0. Listed in the KEV catalogue: 0.
Vulnerabilities: 4
CGI implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to OS command injection.
WebDAV implementation in Yaws web server versions 1.81 to 2.0.7 is vulnerable to XXE injection.
yaws_config.erl in Yaws through 2.0.2 and/or 2.0.7 loads obsolete TLS ciphers, as demonstrated by ones that allow Sweet32 attacks, if running on an Erlang/OTP virtual machine with a version less than 21.0.
Yaws 1.85 writes data to a log file without sanitizing non-printable characters, which might allow remote attackers to modify a window's title, or possibly execute arbitrary commands or overwrite files, via an HTTP request containing an escape sequence for a terminal emulator.
Check your installed stack and versions against the current vulnerability feeds.