p PatchFirst

CVE-2020-8286

CVE-2020-8286

This page contains facts from public vulnerability sources. Check the original advisory before updating.

curl 7.41.0 through 7.73.0 is vulnerable to an improper check for certificate revocation due to insufficient verification of the OCSP response.

CVSS 7.5 · High · EPSS 4.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • https://github.com/curl/curl

    Versions
    • 7.41.0 to and including 7.73.0: Affected

    No fix published

  • curl Debian:12

    Affected ranges
    • ECOSYSTEM: < 7.74.0-1

    Update to 7.74.0-1

  • curl Debian:13

    Affected ranges
    • ECOSYSTEM: < 7.74.0-1

    Update to 7.74.0-1

  • curl Debian:14

    Affected ranges
    • ECOSYSTEM: < 7.74.0-1

    Update to 7.74.0-1

  • curl Ubuntu:16.04:LTS

    Versions
    • 7.43.0-1ubuntu2
    • 7.45.0-1ubuntu1
    • 7.46.0-1ubuntu1
    • 7.47.0-1ubuntu1
    • 7.47.0-1ubuntu2
    • 7.47.0-1ubuntu2.1
    • 7.47.0-1ubuntu2.2
    • 7.47.0-1ubuntu2.3
    • 7.47.0-1ubuntu2.4
    • 7.47.0-1ubuntu2.5
    • 7.47.0-1ubuntu2.6
    • 7.47.0-1ubuntu2.7
    • 7.47.0-1ubuntu2.8
    • 7.47.0-1ubuntu2.9
    • 7.47.0-1ubuntu2.11
    • 7.47.0-1ubuntu2.12
    • 7.47.0-1ubuntu2.13
    • 7.47.0-1ubuntu2.14
    • 7.47.0-1ubuntu2.15
    • 7.47.0-1ubuntu2.16
    Affected ranges
    • ECOSYSTEM: < 7.47.0-1ubuntu2.18

    Update to 7.47.0-1ubuntu2.18

  • curl Ubuntu:18.04:LTS

    Versions
    • 7.55.1-1ubuntu2
    • 7.55.1-1ubuntu2.1
    • 7.57.0-1ubuntu1
    • 7.58.0-2ubuntu1
    • 7.58.0-2ubuntu2
    • 7.58.0-2ubuntu3
    • 7.58.0-2ubuntu3.1
    • 7.58.0-2ubuntu3.2
    • 7.58.0-2ubuntu3.3
    • 7.58.0-2ubuntu3.5
    • 7.58.0-2ubuntu3.6
    • 7.58.0-2ubuntu3.7
    • 7.58.0-2ubuntu3.8
    • 7.58.0-2ubuntu3.9
    • 7.58.0-2ubuntu3.10
    Affected ranges
    • ECOSYSTEM: < 7.58.0-2ubuntu3.12

    Update to 7.58.0-2ubuntu3.12

  • curl Ubuntu:20.04:LTS

    Versions
    • 7.65.3-1ubuntu3
    • 7.65.3-1ubuntu4
    • 7.66.0-1ubuntu1
    • 7.67.0-2ubuntu1
    • 7.68.0-1ubuntu1
    • 7.68.0-1ubuntu2
    • 7.68.0-1ubuntu2.1
    • 7.68.0-1ubuntu2.2
    Affected ranges
    • ECOSYSTEM: < 7.68.0-1ubuntu2.4

    Update to 7.68.0-1ubuntu2.4

Original sources

Check your server →