CVE-2021-22116
CVE-2021-22116
This page contains facts from public vulnerability sources. Check the original advisory before updating.
RabbitMQ all versions prior to 3.8.16 are prone to a denial of service vulnerability due to improper input validation in AMQP 1.0 client connection endpoint. A malicious user can exploit the vulnerability by sending malicious AMQP messages to the target RabbitMQ instance having the AMQP 1.0 plugin enabled.
CVSS 7.5 · High · EPSS 1.4% · Fix available
- Published
- Updated
Affected products and versions
rabbitmq
- Versions
- RabbitMQ prior to version 3.8.16: Affected
No fix published
rabbitmq-server Debian:12
- Affected ranges
- ECOSYSTEM: < 3.9.4-1
Update to 3.9.4-1
rabbitmq-server Debian:13
- Affected ranges
- ECOSYSTEM: < 3.9.4-1
Update to 3.9.4-1
rabbitmq-server Debian:14
- Affected ranges
- ECOSYSTEM: < 3.9.4-1
Update to 3.9.4-1
rabbitmq-server Ubuntu:Pro:16.04:LTS
- Versions
- 3.5.4-1
- 3.5.4-3
- 3.5.4-3.1
- 3.5.7-1
- 3.5.7-1ubuntu0.16.04.1
- 3.5.7-1ubuntu0.16.04.2
- 3.5.7-1ubuntu0.16.04.4
- Affected ranges
- ECOSYSTEM: < 3.5.7-1ubuntu0.16.04.4+esm1
Update to 3.5.7-1ubuntu0.16.04.4+esm1
rabbitmq-server Ubuntu:18.04:LTS
- Versions
- 3.6.10-1
- 3.6.10-1ubuntu0.1
- 3.6.10-1ubuntu0.3
- 3.6.10-1ubuntu0.4
- Affected ranges
- ECOSYSTEM: < 3.6.10-1ubuntu0.5
Update to 3.6.10-1ubuntu0.5
rabbitmq-server Ubuntu:20.04:LTS
- Versions
- 3.7.8-4ubuntu2
- 3.7.18-1
- 3.8.2-0ubuntu1
- 3.8.2-0ubuntu1.1
- 3.8.2-0ubuntu1.2
- Affected ranges
- ECOSYSTEM: < 3.8.2-0ubuntu1.3
Update to 3.8.2-0ubuntu1.3
rabbitmq-server Ubuntu:22.04:LTS
- Affected ranges
- ECOSYSTEM: < 3.8.9-3ubuntu1
Update to 3.8.9-3ubuntu1