p PatchFirst

PatchFirst · Latest vulnerabilities

rabbitmq-server vulnerabilities

Vulnerabilities published for rabbitmq-server in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2021-22116

    High · CVSS 7.5EPSS 1.39%Fix available

    CVE-2021-22116

    RabbitMQ all versions prior to 3.8.16 are prone to a denial of service vulnerability due to improper input validation in AMQP 1.0 client connection endpoint. A malicious user can exploit the vulnerability by sending malicious AMQP messages to the target RabbitMQ instance having the AMQP 1.0 plugin enabled.

    • Update to 3.6.10-1ubuntu0.5
    Published Updated
  2. CVE-2019-11287

    Medium · CVSS 4.5EPSS 4.4%Fix available

    RabbitMQ Web Management Plugin DoS via heap overflow

    Pivotal RabbitMQ, versions 3.7.x prior to 3.7.21 and 3.8.x prior to 3.8.1, and RabbitMQ for Pivotal Platform, 1.16.x versions prior to 1.16.7 and 1.17.x versions prior to 1.17.4, contain a web management plugin that is vulnerable to a denial of service attack. The "X-Reason" HTTP Header can be leveraged to insert a malicious Erlang format string that will expand and consume the heap, resulting in the server crashing.

    • Update to 3.6.10-1ubuntu0.5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →