p PatchFirst

CVE-2021-23358

CVE-2021-23358 · Arbitrary Code Injection

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The package underscore from 1.13.0-0 and before 1.13.0-2, from 1.3.2 and before 1.12.1 are vulnerable to Arbitrary Code Injection via the template function, particularly when a variable property is passed as an argument as it is not sanitized.

CVSS 3.3 · Low · EPSS 4.2% · Fix available

Published
Updated

Stack: system · node

Affected products and versions

  • underscore

    Versions
    • ≥ 1.13.0-0, < unspecified: Affected (custom)
    • ≥ unspecified, < 1.13.0-2: Affected (custom)
    • ≥ 1.3.2, < unspecified: Affected (custom)
    • ≥ unspecified, < 1.12.1: Affected (custom)

    Update to 1.12.1; Update to 1.13.0-2

  • underscore Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.9.1~dfsg-2

    Update to 1.9.1~dfsg-2

  • underscore Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.9.1~dfsg-2

    Update to 1.9.1~dfsg-2

  • underscore Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.9.1~dfsg-2

    Update to 1.9.1~dfsg-2

  • underscore npm

    Affected ranges
    • SEMVER: ≥ 1.3.2, < 1.12.1

    Update to 1.12.1

  • underscore Ubuntu:Pro:14.04:LTS

    Versions
    • 1.4.4-2ubuntu1
    Affected ranges
    • ECOSYSTEM: < 1.4.4-2ubuntu1+esm1

    Update to 1.4.4-2ubuntu1+esm1

  • underscore Ubuntu:16.04:LTS

    Versions
    • 1.7.0~dfsg-1ubuntu1
    Affected ranges
    • ECOSYSTEM: < 1.7.0~dfsg-1ubuntu1.1

    Update to 1.7.0~dfsg-1ubuntu1.1

  • underscore Ubuntu:18.04:LTS

    Versions
    • 1.8.3~dfsg-1
    Affected ranges
    • ECOSYSTEM: < 1.8.3~dfsg-1ubuntu0.1

    Update to 1.8.3~dfsg-1ubuntu0.1

  • underscore Ubuntu:20.04:LTS

    Versions
    • 1.9.1~dfsg-1
    Affected ranges
    • ECOSYSTEM: < 1.9.1~dfsg-1ubuntu0.20.04.1

    Update to 1.9.1~dfsg-1ubuntu0.20.04.1

Original sources

Check your server →