CVE-2021-29450
CVE-2021-29450 · WordPress Authenticated disclosure of password-protected posts and pages
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Wordpress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.
CVSS 6.5 · Medium · EPSS 2.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
wordpress-develop
- Versions
- >= 4.70,< 5.7.1: Affected
No fix published
wordpress Debian:12
- Affected ranges
- ECOSYSTEM: < 5.7.1+dfsg1-1
Update to 5.7.1+dfsg1-1
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 5.7.1+dfsg1-1
Update to 5.7.1+dfsg1-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 5.7.1+dfsg1-1
Update to 5.7.1+dfsg1-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:18.04:LTS
- Versions
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:20.04:LTS
- Versions
- 5.2.2+dfsg1-1
- 5.2.4+dfsg1-1
- 5.3.2+dfsg1-1
- 5.3.2+dfsg1-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:22.04:LTS
- Versions
- 5.7.1+dfsg1-2ubuntu1
- 5.8.1+dfsg1-2ubuntu1
- 5.8.2+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:24.04:LTS
- Versions
- 6.2+dfsg1-1ubuntu1
- 6.4.3+dfsg1-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:25.10
- Versions
- 6.7.2+dfsg1-1.1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:26.10
- Versions
- 6.7.2+dfsg1-1.1ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:26.04:LTS
- Versions
- 6.7.2+dfsg1-1.1ubuntu1
- 6.7.2+dfsg1-1.1ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published