p PatchFirst

CVE-2021-3185

CVE-2021-3185

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A flaw was found in the gstreamer h264 component of gst-plugins-bad before v1.18.1 where when parsing a h264 header, an attacker could cause the stack to be smashed, memory corruption and possibly code execution.

CVSS 9.8 · Critical · EPSS 2.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gstreamer

    Versions
    • Fixed in gst-plugins-bad-1.18.1: Affected

    No fix published

  • gst-plugins-bad1.0 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.18.1-1

    Update to 1.18.1-1

  • gst-plugins-bad1.0 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.18.1-1

    Update to 1.18.1-1

  • gst-plugins-bad1.0 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.18.1-1

    Update to 1.18.1-1

  • gst-plugins-bad1.0 Ubuntu:Pro:14.04:LTS

    Versions
    • 1.2.0-3ubuntu5
    • 1.2.1-1ubuntu1
    • 1.2.1-1ubuntu2
    • 1.2.2-1ubuntu1
    • 1.2.2-1ubuntu2
    • 1.2.2-1ubuntu4
    • 1.2.3-1ubuntu1
    • 1.2.3-1ubuntu2
    • 1.2.4-1~ubuntu1
    • 1.2.4-1~ubuntu1.1
    • 1.2.4-1~ubuntu1.1+esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • gst-plugins-bad1.0 Ubuntu:Pro:16.04:LTS

    Versions
    • 1.6.0-1ubuntu1
    • 1.6.1-1ubuntu1
    • 1.6.2-1ubuntu1
    • 1.7.1-1ubuntu1
    • 1.7.1-1ubuntu3
    • 1.7.1-1ubuntu4
    • 1.7.2-1ubuntu1
    • 1.7.90-1ubuntu2
    • 1.7.91-1ubuntu1
    • 1.8.0-1ubuntu1
    • 1.8.1-1ubuntu0.1
    • 1.8.2-1ubuntu0.1
    • 1.8.2-1ubuntu0.2
    • 1.8.3-1ubuntu0.2
    • 1.8.3-1ubuntu0.2+esm1
    • 1.8.3-1ubuntu0.2+esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • gst-plugins-bad1.0 Ubuntu:Pro:18.04:LTS

    Versions
    • 1.12.3-1ubuntu1
    • 1.12.3-1ubuntu2
    • 1.12.3-2ubuntu1
    • 1.12.4-2ubuntu1
    • 1.12.4-2ubuntu2
    • 1.13.1-1ubuntu1
    • 1.13.91-1ubuntu1
    • 1.14.0-1ubuntu1
    • 1.14.1-1ubuntu1~ubuntu18.04.1
    • 1.14.4-1ubuntu1~ubuntu18.04.1
    • 1.14.5-0ubuntu1~18.04.1
    • 1.14.5-0ubuntu1~18.04.1+esm1
    • 1.14.5-0ubuntu1~18.04.1+esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →