CVE-2021-34551
CVE-2021-34551
This page contains facts from public vulnerability sources. Check the original advisory before updating.
PHPMailer before 6.5.0 on Windows allows remote code execution if lang_path is untrusted data and has a UNC pathname.
CVSS 8.1 · High · EPSS 2.8% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
phpmailer/phpmailer Packagist
- Versions
- v5.2.10
- v5.2.11
- v5.2.12
- v5.2.13
- v5.2.14
- v5.2.15
- v5.2.16
- v5.2.17
- v5.2.18
- v5.2.19
- v5.2.2
- v5.2.20
- v5.2.21
- v5.2.22
- v5.2.23
- v5.2.24
- v5.2.25
- v5.2.26
- v5.2.27
- v5.2.28
- v5.2.4
- v5.2.5
- v5.2.6
- v5.2.7
- v5.2.8
- v5.2.9
- v6.0.0
- v6.0.0rc1
- v6.0.0rc2
- v6.0.0rc3
- v6.0.0rc4
- v6.0.0rc5
- v6.0.1
- v6.0.2
- v6.0.3
- v6.0.4
- v6.0.5
- v6.0.6
- v6.0.7
- v6.1.0
- v6.1.1
- v6.1.2
- v6.1.3
- v6.1.4
- v6.1.5
- v6.1.6
- v6.1.7
- v6.1.8
- v6.2.0
- v6.3.0
- v6.4.0
- v6.4.1
- Affected ranges
- ECOSYSTEM: < 6.5.0
Update to 6.5.0
Original sources
- https://github.com/PHPMailer/PHPMailer/blob/master/SECURITY.md
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FJYSOFCUBS67J3TKR74SD3C454N7VTYM/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3YRMWGA4VTMXFB22KICMB7YMFZNFV3EJ/
- https://nvd.nist.gov/vuln/detail/CVE-2021-34551