p PatchFirst

CVE-2021-3497

CVE-2021-3497

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GStreamer before 1.18.4 might access already-freed memory in error code paths when demuxing certain malformed Matroska files.

CVSS 7.8 · High · EPSS 1.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • gstreamer-plugins-good

    Versions
    • gstreamer-plugins-good 1.18.4: Affected

    No fix published

  • gst-plugins-good1.0 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.18.4-2

    Update to 1.18.4-2

  • gst-plugins-good1.0 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.18.4-2

    Update to 1.18.4-2

  • gst-plugins-good1.0 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.18.4-2

    Update to 1.18.4-2

  • gst-plugins-good1.0 Ubuntu:16.04:LTS

    Versions
    • 1.6.0-1ubuntu1
    • 1.6.1-1ubuntu1
    • 1.6.2-1ubuntu1
    • 1.7.1-1ubuntu1
    • 1.7.2-1ubuntu1
    • 1.7.90-1ubuntu1
    • 1.7.91-1ubuntu1
    • 1.8.0-1ubuntu1
    • 1.8.1-1ubuntu0.1
    • 1.8.2-1ubuntu0.1
    • 1.8.2-1ubuntu0.2
    • 1.8.2-1ubuntu0.3
    • 1.8.3-1ubuntu0.3
    • 1.8.3-1ubuntu0.4
    Affected ranges
    • ECOSYSTEM: < 1.8.3-1ubuntu0.5

    Update to 1.8.3-1ubuntu0.5

  • gst-plugins-good1.0 Ubuntu:18.04:LTS

    Versions
    • 1.12.3-1ubuntu1
    • 1.12.4-1ubuntu1
    • 1.13.1-1ubuntu1
    • 1.13.91-1ubuntu1
    • 1.14.0-1ubuntu1
    • 1.14.1-1ubuntu1~ubuntu18.04.1
    • 1.14.4-1ubuntu1~ubuntu18.04.1
    • 1.14.5-0ubuntu1~18.04.1
    Affected ranges
    • ECOSYSTEM: < 1.14.5-0ubuntu1~18.04.2

    Update to 1.14.5-0ubuntu1~18.04.2

  • gst-plugins-good1.0 Ubuntu:20.04:LTS

    Versions
    • 1.16.1-1ubuntu1
    • 1.16.2-1ubuntu1
    • 1.16.2-1ubuntu2
    Affected ranges
    • ECOSYSTEM: < 1.16.2-1ubuntu2.1

    Update to 1.16.2-1ubuntu2.1

Original sources

Check your server →