CVE-2021-3517
CVE-2021-3517
This page contains facts from public vulnerability sources. Check the original advisory before updating.
There is a flaw in the xml entity encoding functionality of libxml2 in versions before 2.9.11. An attacker who is able to supply a crafted file to be processed by an application linked with the affected functionality of libxml2 could trigger an out-of-bounds read. The most likely impact of this flaw is to application availability, with some potential impact to confidentiality and integrity if an attacker is able to use memory information to further exploit the application.
CVSS 8.6 · High · EPSS 17.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
libxml2
- Versions
- libxml2 2.9.11: Affected
No fix published
libxml2 Debian:12
- Affected ranges
- ECOSYSTEM: < 2.9.10+dfsg-6.6
Update to 2.9.10+dfsg-6.6
libxml2 Debian:13
- Affected ranges
- ECOSYSTEM: < 2.9.10+dfsg-6.6
Update to 2.9.10+dfsg-6.6
libxml2 Debian:14
- Affected ranges
- ECOSYSTEM: < 2.9.10+dfsg-6.6
Update to 2.9.10+dfsg-6.6
libxml2 Ubuntu:Pro:14.04:LTS
- Versions
- 2.9.1+dfsg1-3ubuntu2
- 2.9.1+dfsg1-3ubuntu3
- 2.9.1+dfsg1-3ubuntu4
- 2.9.1+dfsg1-3ubuntu4.1
- 2.9.1+dfsg1-3ubuntu4.2
- 2.9.1+dfsg1-3ubuntu4.3
- 2.9.1+dfsg1-3ubuntu4.4
- 2.9.1+dfsg1-3ubuntu4.5
- 2.9.1+dfsg1-3ubuntu4.6
- 2.9.1+dfsg1-3ubuntu4.7
- 2.9.1+dfsg1-3ubuntu4.8
- 2.9.1+dfsg1-3ubuntu4.9
- 2.9.1+dfsg1-3ubuntu4.10
- 2.9.1+dfsg1-3ubuntu4.11
- 2.9.1+dfsg1-3ubuntu4.12
- 2.9.1+dfsg1-3ubuntu4.13
- 2.9.1+dfsg1-3ubuntu4.13+esm1
- Affected ranges
- ECOSYSTEM: < 2.9.1+dfsg1-3ubuntu4.13+esm2
Update to 2.9.1+dfsg1-3ubuntu4.13+esm2
libxml2 Ubuntu:Pro:16.04:LTS
- Versions
- 2.9.2+zdfsg1-4
- 2.9.2+zdfsg1-4ubuntu1
- 2.9.2+zdfsg1-4ubuntu2
- 2.9.2+zdfsg1-4ubuntu3
- 2.9.3+dfsg1-1
- 2.9.3+dfsg1-1ubuntu0.1
- 2.9.3+dfsg1-1ubuntu0.2
- 2.9.3+dfsg1-1ubuntu0.3
- 2.9.3+dfsg1-1ubuntu0.4
- 2.9.3+dfsg1-1ubuntu0.5
- 2.9.3+dfsg1-1ubuntu0.6
- 2.9.3+dfsg1-1ubuntu0.7
- Affected ranges
- ECOSYSTEM: < 2.9.3+dfsg1-1ubuntu0.7+esm1
Update to 2.9.3+dfsg1-1ubuntu0.7+esm1
libxml2 Ubuntu:18.04:LTS
- Versions
- 2.9.4+dfsg1-4ubuntu1
- 2.9.4+dfsg1-5ubuntu1
- 2.9.4+dfsg1-5ubuntu2
- 2.9.4+dfsg1-5.1ubuntu1
- 2.9.4+dfsg1-5.2ubuntu1
- 2.9.4+dfsg1-6.1ubuntu1
- 2.9.4+dfsg1-6.1ubuntu1.2
- 2.9.4+dfsg1-6.1ubuntu1.3
- Affected ranges
- ECOSYSTEM: < 2.9.4+dfsg1-6.1ubuntu1.4
Update to 2.9.4+dfsg1-6.1ubuntu1.4
libxml2 Ubuntu:20.04:LTS
- Versions
- 2.9.4+dfsg1-7ubuntu3
- 2.9.4+dfsg1-7ubuntu5
- 2.9.4+dfsg1-8ubuntu1
- 2.9.4+dfsg1-8ubuntu2
- 2.9.4+dfsg1-8ubuntu3
- 2.9.10+dfsg-1ubuntu3
- 2.9.10+dfsg-4build1
- 2.9.10+dfsg-5
- Affected ranges
- ECOSYSTEM: < 2.9.10+dfsg-5ubuntu0.20.04.1
Update to 2.9.10+dfsg-5ubuntu0.20.04.1
Original sources
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QVM4UJ3376I6ZVOYMHBNX4GY3NIV52WV/
- https://lists.debian.org/debian-lts-announce/2021/05/msg00008.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1954232
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BZOMV5J4PMZAORVT64BKLV6YIZAFDGX6/
- https://lists.apache.org/thread.html/rf4c02775860db415b4955778a131c2795223f61cb8c6a450893651e4%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.apache.org/thread.html/r58af02e294bd07f487e2c64ffc0a29b837db5600e33b6e698b9d696b%40%3Cissues.bookkeeper.apache.org%3E
- https://security.gentoo.org/glsa/202107-05
- https://security.netapp.com/advisory/ntap-20210625-0002/
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://www.oracle.com/security-alerts/cpujan2022.html
- https://security.netapp.com/advisory/ntap-20211022-0004/
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://www.oracle.com/security-alerts/cpujul2022.html
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-3517