p PatchFirst

PatchFirst · Latest vulnerabilities

libxml2 vulnerabilities

Vulnerabilities published for libxml2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 22

  1. CVE-2025-32415

    Low · CVSS 2.9EPSS 0.59%Fix available

    CVE-2025-32415

    In libxml2 before 2.13.8 and 2.14.x before 2.14.2, xmlSchemaIDCFillNodeTables in xmlschemas.c has a heap-based buffer under-read. To exploit this, a crafted XML document must be validated against an XML schema with certain identity constraints, or a crafted XML schema must be used.

    • Update to 2.9.10+dfsg-5ubuntu0.20.04.10
    Published Updated
  2. CVE-2025-32414

    Medium · CVSS 5.6EPSS 0.38%Fix available

    CVE-2025-32414

    In libxml2 before 2.13.8 and 2.14.x before 2.14.2, out-of-bounds memory access can occur in the Python API (Python bindings) because of an incorrect return value. This occurs in xmlPythonFileRead and xmlPythonFileReadRaw because of a difference between bytes and characters.

    • Update to 2.9.10+dfsg-5ubuntu0.20.04.10
    Published Updated
  3. CVE-2024-56171

    High · CVSS 7.8EPSS 1.18%Public exploitFix available

    CVE-2024-56171

    libxml2 before 2.12.10 and 2.13.x before 2.13.6 has a use-after-free in xmlSchemaIDCFillNodeTables and xmlSchemaBubbleIDCNodeTables in xmlschemas.c. To exploit this, a crafted XML document must be validated against an XML schema with certain identity constraints, or a crafted XML schema must be used.

    • Update to 2.9.10+dfsg-5ubuntu0.20.04.9
    Published Updated
  4. CVE-2023-29469

    Medium · CVSS 6.5EPSS 1.31%Fix available

    CVE-2023-29469

    An issue was discovered in libxml2 before 2.10.4. When hashing empty dict strings in a crafted XML document, xmlDictComputeFastKey in dict.c can produce non-deterministic values, leading to various logic and memory errors, such as a double free. This behavior occurs because there is an attempt to use the first byte of an empty string, and any value is possible (not solely the '\0' value).

    • Update to 2.9.10+dfsg-5ubuntu0.20.04.6
    Published Updated
  5. CVE-2022-40303

    High · CVSS 7.5EPSS 41.37%Fix available

    CVE-2022-40303

    An issue was discovered in libxml2 before 2.10.3. When parsing a multi-gigabyte XML document with the XML_PARSE_HUGE parser option enabled, several integer counters can overflow. This results in an attempt to access an array at a negative 2GB offset, typically leading to a segmentation fault.

    • Update to 2.9.10+dfsg-5ubuntu0.20.04.5
    Published Updated
  6. CVE-2022-2309

    Medium · CVSS 5.3EPSS 2.45%Fix available

    NULL Pointer Dereference in lxml/lxml

    NULL Pointer Dereference allows attackers to cause a denial of service (or application crash). This only applies when lxml is used together with libxml2 2.9.10 through 2.9.14. libxml2 2.9.9 and earlier are not affected. It allows triggering crashes through forged input data, given a vulnerable code sequence in the application. The vulnerability is caused by the iterwalk function (also used by the canonicalize function). Such code shouldn't be in wide-spread use, given that parsing + iterwalk would usually be replaced with the more efficient iterparse function. However, an XML converter that serialises to C14N would also be vulnerable, for exa

    • Update to 2.9.10+dfsg-5ubuntu0.20.04.5
    Published Updated
  7. CVE-2022-29824

    Medium · CVSS 6.5EPSS 3.75%Fix available

    CVE-2022-29824

    In libxml2 before 2.9.14, several buffer handling functions in buf.c (xmlBuf*) and tree.c (xmlBuffer*) don't check for integer overflows. This can result in out-of-bounds memory writes. Exploitation requires a victim to open a crafted, multi-gigabyte XML file. Other software using libxml2's buffer functions, for example libxslt through 1.1.35, is affected as well.

    • Update to 2.9.10+dfsg-5ubuntu0.20.04.3
    Published Updated
  8. CVE-2021-3517

    High · CVSS 8.6EPSS 16.99%Fix available

    CVE-2021-3517

    There is a flaw in the xml entity encoding functionality of libxml2 in versions before 2.9.11. An attacker who is able to supply a crafted file to be processed by an application linked with the affected functionality of libxml2 could trigger an out-of-bounds read. The most likely impact of this flaw is to application availability, with some potential impact to confidentiality and integrity if an attacker is able to use memory information to further exploit the application.

    • Update to 2.9.10+dfsg-5ubuntu0.20.04.1
    Published Updated
  9. CVE-2021-3518

    High · CVSS 8.8EPSS 21.86%Fix available

    CVE-2021-3518

    There's a flaw in libxml2 in versions before 2.9.11. An attacker who is able to submit a crafted file to be processed by an application linked with libxml2 could trigger a use-after-free. The greatest impact from this flaw is to confidentiality, integrity, and availability.

    • Update to 2.9.10+dfsg-5ubuntu0.20.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →