p PatchFirst

CVE-2021-3520

CVE-2021-3520

This page contains facts from public vulnerability sources. Check the original advisory before updating.

There's a flaw in lz4. An attacker who submits a crafted file to an application linked with lz4 may be able to trigger an integer overflow, leading to calling of memmove() on a negative size argument, causing an out-of-bounds write and/or a crash. The greatest impact of this flaw is to availability, with some potential impact to confidentiality and integrity as well.

CVSS 9.8 · Critical · EPSS 3.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • lz4

    Versions
    • lz4-1.8.3: Affected

    No fix published

  • lz4 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.9.3-2

    Update to 1.9.3-2

  • lz4 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.9.3-2

    Update to 1.9.3-2

  • lz4 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.9.3-2

    Update to 1.9.3-2

  • lz4 Ubuntu:Pro:14.04:LTS

    Versions
    • 0.0~r94-2
    • 0.0~r99-1
    • 0.0~r107-1
    • 0.0~r109-1
    • 0.0~r114-2ubuntu1
    • 0.0~r114-2ubuntu1+esm1
    Affected ranges
    • ECOSYSTEM: < 0.0~r114-2ubuntu1+esm2

    Update to 0.0~r114-2ubuntu1+esm2

  • lz4 Ubuntu:Pro:16.04:LTS

    Versions
    • 0.0~r131-1
    • 0.0~r131-2
    • 0.0~r131-2ubuntu2
    Affected ranges
    • ECOSYSTEM: < 0.0~r131-2ubuntu2+esm1

    Update to 0.0~r131-2ubuntu2+esm1

  • lz4 Ubuntu:18.04:LTS

    Versions
    • 0.0~r131-2ubuntu2
    • 0.0~r131-2ubuntu3
    Affected ranges
    • ECOSYSTEM: < 0.0~r131-2ubuntu3.1

    Update to 0.0~r131-2ubuntu3.1

  • lz4 Ubuntu:20.04:LTS

    Versions
    • 1.9.1-1
    • 1.9.1-2
    • 1.9.2-2
    Affected ranges
    • ECOSYSTEM: < 1.9.2-2ubuntu0.20.04.1

    Update to 1.9.2-2ubuntu0.20.04.1

Original sources

Check your server →