p PatchFirst

CVE-2021-3765

CVE-2021-3765 · Inefficient Regular Expression Complexity in validatorjs/validator.js

This page contains facts from public vulnerability sources. Check the original advisory before updating.

validator.js is vulnerable to Inefficient Regular Expression Complexity

CVSS 5.3 · Medium · EPSS 1.8% · Fix available

Published
Updated

Stack: system · node

Affected products and versions

  • validatorjs/validator.js

    Versions
    • ≥ unspecified, < 13.7.0: Affected (custom)

    Update to 13.7.0

  • validator npm

    Affected ranges
    • SEMVER: < 13.7.0

    Update to 13.7.0

  • validator.js Ubuntu:16.04:LTS

    Versions
    • 3.17.0+dfsg1-1
    • 4.7.1+dfsg1-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • validator.js Ubuntu:18.04:LTS

    Versions
    • 4.7.1+dfsg1-1.1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →