p PatchFirst

PatchFirst · Latest vulnerabilities

validator vulnerabilities

Vulnerabilities published for validator in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 10

  1. CVE-2025-12758

    High · CVSS 8.7EPSS 0.55%Fix available

    CVE-2025-12758

    Versions of the package validator before 13.15.22 are vulnerable to Incomplete Filtering of One or More Instances of Special Elements in the isLength() function that does not take into account Unicode variation selectors (\uFE0F, \uFE0E) appearing in a sequence which lead to improper string length calculation. This can lead to an application using isLength for input validation accepting strings significantly longer than intended, resulting in issues like data truncation in databases, buffer overflows in other system components, or denial-of-service.

    • Update to 13.15.22
    Published Updated
  2. CVE-2025-56200

    Medium · CVSS 6.1EPSS 0.32%Fix available

    CVE-2025-56200

    A URL validation bypass vulnerability exists in validator.js through version 13.15.15. The isURL() function uses '://' as a delimiter to parse protocols, while browsers use ':' as the delimiter. This parsing difference allows attackers to bypass protocol and domain validation by crafting URLs leading to XSS and Open Redirect attacks.

    • Update to 13.15.20
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →