p PatchFirst

CVE-2021-40812

CVE-2021-40812

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The GD Graphics Library (aka LibGD) through 2.3.2 has an out-of-bounds read because of the lack of certain gdGetBuf and gdPutBuf return value checks.

CVSS 6.5 · Medium · EPSS 1.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libgd2 Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.3.3-1

    Update to 2.3.3-1

  • libgd2 Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.3.3-1

    Update to 2.3.3-1

  • libgd2 Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.3.3-1

    Update to 2.3.3-1

  • libgd2 Ubuntu:Pro:14.04:LTS

    Versions
    • 2.1.0-2
    • 2.1.0-3
    • 2.1.0-3ubuntu0.1
    • 2.1.0-3ubuntu0.2
    • 2.1.0-3ubuntu0.3
    • 2.1.0-3ubuntu0.5
    • 2.1.0-3ubuntu0.6
    • 2.1.0-3ubuntu0.7
    • 2.1.0-3ubuntu0.8
    • 2.1.0-3ubuntu0.10
    • 2.1.0-3ubuntu0.11
    • 2.1.0-3ubuntu0.11+esm1
    • 2.1.0-3ubuntu0.11+esm2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • libgd2 Ubuntu:Pro:16.04:LTS

    Versions
    • 2.1.1-4build1
    • 2.1.1-4build2
    • 2.1.1-4ubuntu0.16.04.1
    • 2.1.1-4ubuntu0.16.04.2
    • 2.1.1-4ubuntu0.16.04.3
    • 2.1.1-4ubuntu0.16.04.5
    • 2.1.1-4ubuntu0.16.04.6
    • 2.1.1-4ubuntu0.16.04.7
    • 2.1.1-4ubuntu0.16.04.8
    • 2.1.1-4ubuntu0.16.04.10
    • 2.1.1-4ubuntu0.16.04.11
    • 2.1.1-4ubuntu0.16.04.12
    • 2.1.1-4ubuntu0.16.04.12+esm1
    Affected ranges
    • ECOSYSTEM: < 2.1.1-4ubuntu0.16.04.12+esm4

    Update to 2.1.1-4ubuntu0.16.04.12+esm4

  • libgd2 Ubuntu:Pro:18.04:LTS

    Versions
    • 2.2.5-3
    • 2.2.5-4
    • 2.2.5-4ubuntu0.2
    • 2.2.5-4ubuntu0.3
    • 2.2.5-4ubuntu0.4
    • 2.2.5-4ubuntu0.5
    Affected ranges
    • ECOSYSTEM: < 2.2.5-4ubuntu0.5+esm3

    Update to 2.2.5-4ubuntu0.5+esm3

  • libgd2 Ubuntu:20.04:LTS

    Versions
    • 2.2.5-5.2
    • 2.2.5-5.2ubuntu2
    • 2.2.5-5.2ubuntu2.1
    Affected ranges
    • ECOSYSTEM: < 2.2.5-5.2ubuntu2.4

    Update to 2.2.5-5.2ubuntu2.4

  • libgd2 Ubuntu:22.04:LTS

    Versions
    • 2.3.0-2ubuntu1
    • 2.3.0-2ubuntu2
    Affected ranges
    • ECOSYSTEM: < 2.3.0-2ubuntu2.3

    Update to 2.3.0-2ubuntu2.3

Original sources

Check your server →