p PatchFirst

PatchFirst · Latest vulnerabilities

libgd2 vulnerabilities

Vulnerabilities published for libgd2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 7

  1. CVE-2021-40145

    High · CVSS 7.5EPSS 2.13%Fix available

    CVE-2021-40145

    gdImageGd2Ptr in gd_gd2.c in the GD Graphics Library (aka LibGD) through 2.3.2 has a double free. NOTE: the vendor's position is "The GD2 image format is a proprietary image format of libgd. It has to be regarded as being obsolete, and should only be used for development and testing purposes.

    • Update to 2.1.0-3ubuntu0.11+esm2
    Published Updated
  2. CVE-2017-6363

    High · CVSS 8.1EPSS 1.4%Fix available

    CVE-2017-6363

    In the GD Graphics Library (aka LibGD) through 2.2.5, there is a heap-based buffer over-read in tiffWriter in gd_tiff.c. NOTE: the vendor says "In my opinion this issue should not have a CVE, since the GD and GD2 formats are documented to be 'obsolete, and should only be used for development and testing purposes.'

    • Update to 2.1.0-3ubuntu0.11+esm2
    Published Updated
  3. CVE-2019-11038

    Low · CVSS 3.1EPSS 4.33%Fix available

    Uninitialized read in gdImageCreateFromXbm

    When using the gdImageCreateFromXbm() function in the GD Graphics Library (aka LibGD) 2.2.5, as used in the PHP GD extension in PHP versions 7.1.x below 7.1.30, 7.2.x below 7.2.19 and 7.3.x below 7.3.6, it is possible to supply data that will cause the function to use the value of uninitialized variable. This may lead to disclosing contents of the stack that has been left there by previous code.

    • Update to 2.1.0-3ubuntu0.11+esm1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →