p PatchFirst

CVE-2021-43616

CVE-2021-43616

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The npm ci command in npm 7.x and 8.x through 8.1.3 proceeds with an installation even if dependency information in package-lock.json differs from package.json. This behavior is inconsistent with the documentation, and makes it easier for attackers to install malware that was supposed to have been blocked by an exact version match requirement in package-lock.json. NOTE: The npm team believes this is not a vulnerability. It would require someone to socially engineer package.json which has different dependencies than package-lock.json. That user would have to have file system or write access to change dependencies. The npm team states preventing malicious actors from socially engineering or gaining file system access is outside the scope of the npm CLI.

CVSS 9.0 · Critical · EPSS 2.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • npm Debian:12

    Affected ranges
    • ECOSYSTEM: < 8.4.1~ds-1

    Update to 8.4.1~ds-1

  • npm Debian:13

    Affected ranges
    • ECOSYSTEM: < 8.4.1~ds-1

    Update to 8.4.1~ds-1

  • npm Debian:14

    Affected ranges
    • ECOSYSTEM: < 8.4.1~ds-1

    Update to 8.4.1~ds-1

  • npm Ubuntu:22.04:LTS

    Versions
    • 7.5.2+ds-2
    • 7.24.2+ds-1
    • 7.24.2+ds-2
    • 8.3.0~ds-1
    • 8.3.0~ds-2
    • 8.3.2~ds-1
    • 8.5.0~ds-1
    • 8.5.1~ds-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • npm Ubuntu:24.04:LTS

    Versions
    • 9.2.0~ds1-1
    • 9.2.0~ds1-2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • npm Ubuntu:25.10

    Versions
    • 9.2.0~ds1-3
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • npm Ubuntu:26.10

    Versions
    • 9.2.0~ds3-1
    • 11.16.0+ds2-4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • npm Ubuntu:26.04:LTS

    Versions
    • 9.2.0~ds1-3
    • 9.2.0~ds2-2
    • 9.2.0~ds3-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →