CVE-2021-44451
CVE-2021-44451 · API sensitive information leak
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Apache Superset up to and including 1.3.2 allowed for registered database connections password leak for authenticated users. This information could be accessed in a non-trivial way. Users should upgrade to Apache Superset 1.4.0 or higher.
CVSS 7.1 · High · EPSS 7.9% · Public exploit · Fix available
- Published
- Updated
Stack: python
Affected products and versions
apache superset
- Versions
- ≥ Apache Superset, ≤ 1.3.2: Affected (custom)
No fix published
apache-superset PyPI
- Versions
- 0.34.0
- 0.34.1
- 0.35.1
- 0.35.2
- 0.36.0
- 0.37.0
- 0.37.1
- 0.37.2
- 0.38.0
- 0.38.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.2.0
- 1.3.0
- 1.3.1
- 1.3.2
- Affected ranges
- ECOSYSTEM: < 1.4.0
Update to 1.4.0