CVE-2022-21149
CVE-2022-21149 · Cross-site Scripting (XSS)
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The package s-cart/s-cart before 6.9; the package s-cart/core before 6.9 are vulnerable to Cross-site Scripting (XSS) which can lead to cookie stealing of any victim that visits the affected URL so the attacker can gain unauthorized access to that user's account through the stolen cookie.
CVSS 5.4 · Medium · EPSS 0.6% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
s-cart/s-cart
- Versions
- ≥ unspecified, < 6.9: Affected (custom)
Update to 6.9
s-cart/core
- Versions
- ≥ unspecified, < 6.9: Affected (custom)
Update to 6.9
s-cart/core Packagist
- Versions
- 4.0.0
- 4.0.0-beta
- 4.0.1
- 4.0.1.1
- 4.0.1.2
- 4.0.1.3
- 4.0.1.4
- 4.0.1.5
- 4.1.0
- 4.1.0.1
- 4.1.0.2
- 4.1.0.3
- 4.1.0.4
- 4.1.0.5
- 4.1.1
- 4.2.0
- 4.2.1
- 4.2.1.1
- 4.2.1.2
- 4.2.1.3
- 4.2.1.4
- 4.2.1.5
- 4.2.2.0
- 4.2.2.1
- 4.2.2.2
- 4.2.3.0
- 4.3.0
- 4.3.0.1
- 4.3.1
- 4.3.1.1
- 4.3.1.2
- 4.3.2.0
- 4.4.0-beta
- 4.4.0.0
- 4.4.0.1
- 4.4.0.2
- 4.4.0.3
- 4.4.0.4
- 4.4.0.5
- 4.4.1.0
- 4.4.1.1
- 4.4.2.0
- 4.5.0
- 4.5.1
- 4.5.2
- 5.0.0
- 5.0.0-beta
- 5.0.1
- 5.0.2
- 5.0.2.1
- 5.0.3
- 5.0.4
- 5.0.5
- 5.0.6
- 5.0.6.1
- 5.0.6.2
- 5.1.0
- 5.1.1
- 5.1.2
- 5.1.2.1
- 6.0-beta
- 6.0.1
- 6.0.2
- 6.0.2.1
- 6.0.2.2
- 6.0.2.3
- 6.0.3
- 6.0.3.1
- 6.0.3.2
- 6.0.3.3
- 6.0.3.4
- 6.0.4
- 6.0.4.1
- 6.0.4.2
- 6.0.4.3
- 6.0.4.4
- 6.0.4.5
- 6.0.4.6
- 6.0.5.0
- 6.0.5.1
- 6.0.5.2
- 6.0.5.3
- 6.0.5.4
- 6.0.6
- 6.0.6.1
- 6.0.6.2
- 6.0.6.3
- 6.0.6.4
- 6.1.0.0
- 6.1.0.1
- 6.1.0.2
- 6.1.0.3
- 6.1.1.0
- 6.1.1.1
- 6.1.2
- 6.1.2.3
- 6.1.3
- 6.2.0
- 6.2.1
- 6.2.1.1
- 6.2.1.2
- 6.2.1.3
- 6.2.1.4
- 6.2.1.5
- 6.2.1.6
- 6.2.1.7
- 6.2.1.8
- 6.2.2.0
- 6.2.2.1
- 6.2.2.2
- 6.2.2.3
- 6.2.3.0
- 6.2.3.1
- 6.2.3.2
- 6.2.3.3
- 6.2.3.4
- 6.2.3.5
- 6.2.3.6
- 6.2.3.7
- 6.2.3.8
- 6.3.0
- 6.3.0-beta
- 6.3.0.1
- 6.3.0.2
- 6.3.0.3
- 6.3.0.4
- 6.3.1
- 6.3.1.1
- 6.3.1.2
- 6.3.1.3
- 6.3.3.0
- 6.3.3.1
- 6.3.3.2
- 6.3.3.3
- 6.3.3.4
- 6.3.3.5
- 6.3.3.6
- 6.4.0.0
- 6.4.0.1
- 6.4.0.2
- 6.4.0.3
- 6.4.0.4
- 6.4.0.5
- 6.4.0.6
- 6.4.1.0
- 6.4.1.1
- 6.4.1.2
- 6.4.1.3
- 6.4.1.4
- 6.4.1.5
- 6.4.1.6
- 6.4.1.7
- 6.4.1.8
- 6.4.1.9
- 6.4.2.0
- 6.4.2.1
- 6.4.2.2
- 6.4.2.3
- 6.4.2.4
- 6.4.2.5
- 6.5.0
- 6.5.0-beta
- 6.5.0.1
- 6.5.0.2
- 6.5.0.3
- 6.5.0.4
- 6.5.0.5
- 6.5.0.6
- 6.5.0.7
- 6.5.1.0
- 6.5.1.1
- 6.5.1.2
- 6.5.1.3
- 6.5.1.4
- 6.5.1.5
- 6.5.1.6
- 6.5.1.7
- 6.5.1.8
- 6.5.1.9
- 6.5.2.0
- 6.5.2.1
- 6.5.2.10
- 6.5.2.2
- 6.5.2.3
- 6.5.2.4
- 6.5.2.5
- 6.5.2.6
- 6.5.2.7
- 6.5.2.8
- 6.5.2.9
- 6.6.0.0
- 6.6.0.0-beta
- 6.6.0.1
- 6.6.0.2
- 6.6.0.3
- 6.6.0.4
- 6.6.0.5
- 6.6.0.6
- 6.6.1.0
- 6.6.1.1
- 6.6.1.2
- 6.6.2.0
- 6.6.2.1
- 6.6.2.2
- 6.6.2.3
- 6.6.2.4
- 6.6.2.5
- 6.6.2.6
- 6.6.2.7
- 6.6.2.8
- 6.7.0
- 6.7.1
- 6.7.10
- 6.7.11
- 6.7.12
- 6.7.13
- 6.7.14
- 6.7.15
- 6.7.16
- 6.7.17
- 6.7.2
- 6.7.3
- 6.7.3.1
- 6.7.3.2
- 6.7.3.3
- 6.7.4
- 6.7.5
- 6.7.6
- 6.7.7
- 6.7.8
- 6.7.9
- 6.8.0
- 6.8.1
- 6.8.10
- 6.8.11
- 6.8.12
- 6.8.13
- 6.8.14
- 6.8.15
- 6.8.16
- 6.8.17
- 6.8.2
- 6.8.3
- 6.8.4
- 6.8.5
- 6.8.6
- 6.8.7
- 6.8.8
- 6.8.9
- Affected ranges
- ECOSYSTEM: < 6.9
Update to 6.9
s-cart/s-cart Packagist
- Affected ranges
- ECOSYSTEM: < 6.9
Update to 6.9