CVE-2022-22707
CVE-2022-22707
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In lighttpd 1.4.46 through 1.4.63, the mod_extforward_Forwarded function of the mod_extforward plugin has a stack-based buffer overflow (4 bytes representing -1), as demonstrated by remote denial of service (daemon crash) in a non-default configuration. The non-default configuration requires handling of the Forwarded header in a somewhat unusual manner. Also, a 32-bit system is much more likely to be affected than a 64-bit system.
CVSS 5.9 · Medium · EPSS 8.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
lighttpd Debian:12
- Affected ranges
- ECOSYSTEM: < 1.4.64-1
Update to 1.4.64-1
lighttpd Debian:13
- Affected ranges
- ECOSYSTEM: < 1.4.64-1
Update to 1.4.64-1
lighttpd Debian:14
- Affected ranges
- ECOSYSTEM: < 1.4.64-1
Update to 1.4.64-1
lighttpd Ubuntu:20.04:LTS
- Versions
- 1.4.53-4ubuntu2
- 1.4.54-2ubuntu1
- 1.4.55-1ubuntu1
- 1.4.55-1ubuntu1.20.04.1
- Affected ranges
- ECOSYSTEM: < 1.4.55-1ubuntu1.20.04.2
Update to 1.4.55-1ubuntu1.20.04.2
lighttpd Ubuntu:22.04:LTS
- Versions
- 1.4.59-1ubuntu2
- 1.4.59-1ubuntu3
- 1.4.63-1ubuntu1
- 1.4.63-1ubuntu2
- 1.4.63-1ubuntu3
- Affected ranges
- ECOSYSTEM: < 1.4.63-1ubuntu3.1
Update to 1.4.63-1ubuntu3.1