p PatchFirst

PatchFirst · Latest vulnerabilities

lighttpd vulnerabilities

Vulnerabilities published for lighttpd in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2025-12642

    Medium · CVSS 6.9EPSS 0.37%No fix published

    HTTP Header Smuggling via Trailer Merge

    lighttpd1.4.80 incorrectly merged trailer fields into headers after http request parsing. This behavior can be exploited to conduct HTTP Header Smuggling attacks. Successful exploitation may allow an attacker to: * Bypass access control rules * Inject unsafe input into backend logic that trusts request headers * Execute HTTP Request Smuggling attacks under some conditions This issue affects lighttpd1.4.80

    Published Updated
  2. CVE-2025-8671

    High · CVSS 7.5EPSS 3.62%No fix published

    CVE-2025-8671

    A mismatch caused by client-triggered server-sent stream resets between HTTP/2 specifications and the internal architectures of some HTTP/2 implementations may result in excessive server resource consumption leading to denial-of-service (DoS). By opening streams and then rapidly triggering the server to reset them—using malformed frames or flow control errors—an attacker can exploit incorrect stream accounting. Streams reset by the server are considered closed at the protocol level, even though backend processing continues. This allows a client to cause the server to handle an unbounded number of concurrent streams on a single connection. Th

    Published Updated
  3. CVE-2022-22707

    Medium · CVSS 5.9EPSS 8.93%Fix available

    CVE-2022-22707

    In lighttpd 1.4.46 through 1.4.63, the mod_extforward_Forwarded function of the mod_extforward plugin has a stack-based buffer overflow (4 bytes representing -1), as demonstrated by remote denial of service (daemon crash) in a non-default configuration. The non-default configuration requires handling of the Forwarded header in a somewhat unusual manner. Also, a 32-bit system is much more likely to be affected than a 64-bit system.

    • Update to 1.4.55-1ubuntu1.20.04.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →