CVE-2022-23303
CVE-2022-23303
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The implementations of SAE in hostapd before 2.10 and wpa_supplicant before 2.10 are vulnerable to side channel attacks as a result of cache access patterns. NOTE: this issue exists because of an incomplete fix for CVE-2019-9494.
CVSS 9.8 · Critical · EPSS 3.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wpa Debian:12
- Affected ranges
- ECOSYSTEM: < 2:2.10-1
Update to 2:2.10-1
wpa Debian:13
- Affected ranges
- ECOSYSTEM: < 2:2.10-1
Update to 2:2.10-1
wpa Debian:14
- Affected ranges
- ECOSYSTEM: < 2:2.10-1
Update to 2:2.10-1
wpa Ubuntu:20.04:LTS
- Versions
- 2:2.9-1ubuntu2
- 2:2.9-1ubuntu3
- 2:2.9-1ubuntu4
- 2:2.9-1ubuntu4.1
- 2:2.9-1ubuntu4.2
- 2:2.9-1ubuntu4.3
- 2:2.9-1ubuntu4.4
- Affected ranges
- ECOSYSTEM: < 2:2.9-1ubuntu4.6
Update to 2:2.9-1ubuntu4.6
Original sources
- https://w1.fi/security/2022-1/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YPDHU5MV464CZBPX7N2SNMUYP6DFIBZL/
- https://security.gentoo.org/glsa/202309-16
- https://lists.debian.org/debian-lts-announce/2025/04/msg00019.html
- https://cert-portal.siemens.com/productcert/html/ssa-585531.html
- https://nvd.nist.gov/vuln/detail/CVE-2022-23303