p PatchFirst

PatchFirst · Latest vulnerabilities

wpa vulnerabilities

Vulnerability published for wpa in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 13

  1. CVE-2026-49878

    High · CVSS 7.2EPSS 0.29%No fix published

    CVE-2026-49878

    In wpas_handle_robust_av_scs_recv_action of robust_av.c, there is a possible out-of-bounds write due to a logic error in the code. This could lead to remote code execution with System execution privileges needed. User interaction is not needed for exploitation.

    Published Updated
  2. CVE-2026-78807

    High · CVSS 7.1EPSS 0.08%No fix published

    CVE-2026-78807

    An issue in wpa_supplicant all versions before v.2.12 allows a local attacker to bypass proper network context and AKMP matching for PMKSA caching via missing validation in the driver based PMKSA selection path in wpa.c

    Published Updated
  3. CVE-2022-37660

    Medium · CVSS 6.5EPSS 0.38%Fix available

    CVE-2022-37660

    In hostapd 2.10 and earlier, the PKEX code remains active even after a successful PKEX association. An attacker that successfully bootstrapped public keys with another entity using PKEX in the past, will be able to subvert a future bootstrapping by passively observing public keys, re-using the encrypting element Qi and subtracting it from the captured message M (X = M - Qi). This will result in the public ephemeral key X; the only element required to subvert the PKEX association.

    • Update to 2:2.9-1ubuntu4.6
    Published Updated
  4. CVE-2024-5290

    High · CVSS 8.8EPSS 0.65%Fix available

    CVE-2024-5290

    An issue was discovered in Ubuntu wpa_supplicant that resulted in loading of arbitrary shared objects, which allows a local unprivileged attacker to escalate privileges to the user that wpa_supplicant runs as (usually root). Membership in the netdev group or access to the dbus interface of wpa_supplicant allow an unprivileged user to specify an arbitrary path to a module to be loaded by the wpa_supplicant process; other escalation paths might exist.

    • Update to 2:2.9-1ubuntu4.4
    Published Updated
  5. CVE-2023-52160

    Medium · CVSS 6.5EPSS 1.18%No fix published

    CVE-2023-52160

    The implementation of PEAP in wpa_supplicant through 2.10 allows authentication bypass. For a successful attack, wpa_supplicant must be configured to not verify the network's TLS certificate during Phase 1 authentication, and an eap_peap_decrypt vulnerability can then be abused to skip Phase 2 authentication. The attack vector is sending an EAP-TLV Success packet instead of starting Phase 2. This allows an adversary to impersonate Enterprise Wi-Fi networks.

    Published Updated
  6. CVE-2021-27803

    High · CVSS 7.5EPSS 1.23%Fix available

    CVE-2021-27803

    A vulnerability was discovered in how p2p/p2p_pd.c in wpa_supplicant before 2.10 processes P2P (Wi-Fi Direct) provision discovery requests. It could result in denial of service or other impact (potentially execution of arbitrary code), for an attacker within radio range.

    • Update to 2:2.9-1ubuntu4.3
    Published Updated
  7. CVE-2021-0326

    High · CVSS 7.5EPSS 4.93%Fix available

    CVE-2021-0326

    In p2p_copy_client_info of p2p.c, there is a possible out of bounds write due to a missing bounds check. This could lead to remote code execution if the target device is performing a Wi-Fi Direct search, with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android-10 Android-11 Android-8.1 Android-9Android ID: A-172937525

    • Update to 2:2.9-1ubuntu4.2
    Published Updated
  8. CVE-2019-5062

    High · CVSS 7.4EPSS 0.57%No fix published

    CVE-2019-5062

    An exploitable denial-of-service vulnerability exists in the 802.11w security state handling for hostapd 2.6 connected clients with valid 802.11w sessions. By simulating an incomplete new association, an attacker can trigger a deauthentication against stations using 802.11w, resulting in a denial of service.

    Published Updated
  9. CVE-2019-5061

    High · CVSS 7.4EPSS 0.92%No fix published

    CVE-2019-5061

    An exploitable denial-of-service vulnerability exists in the hostapd 2.6, where an attacker could trigger AP to send IAPP location updates for stations, before the required authentication process has completed. This could lead to different denial of service scenarios, either by causing CAM table attacks, or by leading to traffic flapping if faking already existing clients in other nearby Aps of the same wireless infrastructure. An attacker can forge Authentication and Association Request packets to trigger this vulnerability.

    Published Updated
  10. CVE-2019-9233

    High · CVSS 7.5EPSS 0.83%No fix published

    CVE-2019-9233

    In wpa_supplicant_8, there is a possible out of bounds read due to an incorrect bounds check. This could lead to remote information disclosure with no additional execution privileges needed. User interaction is not needed for exploitation. Product: AndroidVersions: Android-10Android ID: A-122529021

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →